Lookout

cancel
Showing results for 
Search instead for 
Did you mean: 

create new database in MAX

Solved!
Go to solution

Is it possibible to create a database on a network drive share? I keep getting the error: "Unable to create database: Access permission is denied".

I really can't figure this out as...

1) I 'should' have full permissions to the drive letter I want to put the database on.

2) Creating a database on a "D" drive connected on the computer's own SATA works fine.

 

Does MAX somehow just 'know' this is a shared network location, and prevent it's usage?

Any help would be much appreciated, I could not find out thru the help files for MAX if there is such a thing as a 'valid' location for a database.

 

RichA

0 Kudos
Message 1 of 8
(6,338 Views)

If the shared drive is not on your local computer, you may not create database on it. It is not the case whether you have read/write permission on the shared driver, but it is the design of Citadel.

 

If you want to create a database and use that database on another remote computer, you need first to have Citadel installed on that computer. Then, you can expand "Network" and find that computer in MAX, right click it and create database. Actually it is just like controlling the remote computer to create database.

Ryan Shi
National Instruments
0 Kudos
Message 2 of 8
(6,330 Views)

let me give more information. Perhaps there is another method to do what I want.

I have a development/runtime lookout server, and a runtime server only, running on 2 PC's. Lets name them LookoutServer1, and LookoutServer2.

I have a 4 license for clients, and those are running on LookoutClient1 thru 4.

LookoutServer1 is my primary server, it attaches to a PLC via ethernet (all Lookout Servers, and Clients are on the ethernet)

I have a Lookout application running on LookoutServer2 which monitors LookoutServer1, and loads the 'server' application if LookoutServer1 goes down. (this switching all works fine)

 

The issue I have (of course) is that there is no trending history when LookoutServer1 goes down and LookoutServer2 takes over (all functions for controlling the PLC is fine)

Of course this problem is that the database on LookoutServer2 doesn't have that historical data.

 

My solution was to buy a network (ethernet) hard drive, set it up as a letter drive on each LookoutServer1 and 2 and have the database reside on the network hard drive.

But, (as explained in my first post) I couldn't use MAX to setup a database on that drive for both LookoutServer1 and 2 to use.

 

Is there a prefered method to acomplish what I wish to do? (basicly, allow LookoutServer2 to have this historical data, so the clients still have their historical trending)

 

Thanks,

 

RichA

0 Kudos
Message 3 of 8
(6,291 Views)

The idea of redundancy in Lookout is to run the standby server temporarily whenever the primary server is down. Whenever the server comes back, the standby server unloads the process and gives the control back to the primary server. I don't know a straightforward way to accomplish what you want to do.

 

The network hard driver doesn't work because of the design of Citadel, unless someone else has the experience of using a network hard drive for logging and sharing between computers.

 

One option maybe is to periodically archive the database from primary server to the standby server. For example, you have database1 and database 2 on the standby server. database1 is what the standby server process uses. You can use the CitadelControl object on primary server to archive the database to remote database2 periodically, for example everyday or every week. The traces in database2 will be \\standbyserver\database2\primaryservername\process\items.

After the primary server is down, the standby computer needs to rename and archive the data before it loads the server process. It first needs to rename the trace to \\standbyserver\database2\standbyservername\process\items, and archive to the \\standbyserver\database1. Then, the database1 on standby server will have the historical data. These can be done by CitadelControl and RenameTrace objects.

The problem is the data loss between last archive and the primary server down time.

 

But I think if the primary server down can be handled in time and recovers soon, it's not necessary to have the historical data for standby server. The standby server is just for temporarily handling the control and monitor.

Ryan Shi
National Instruments
0 Kudos
Message 4 of 8
(6,268 Views)
Solution
Accepted by topic author reandy

Thank you for your suggestion, it lets me know i have mine configured as recommended. The suggestion is in alignment with how I have mine currently configured. (standby server takes over when primary server goes down. standby server only used until i can get primary server back up. and while the standby server is down, they have trending just for that time.

 

thanks again,

 

RichA

0 Kudos
Message 5 of 8
(6,249 Views)

Hello Ryan,

I actually just did what you suggested in your first reply here. I added the computer through the network browsing and the database I want to access appears, but I cannot see any of the variables contained in the database. When I click on the database an exclamation mark appers over the icon beside the database name.  I am already accessing another database on the same server from a different computer, but I can't seem to create another link.

0 Kudos
Message 6 of 8
(5,596 Views)

What if you access the same database on the same server from a different computer?

Do you want to create the database on remote server from local computer, or just to access the data on remote server?

 

The exclamation mark usually means the problem in Logos communication.

As the server can be accessed by another computer, the problem is probably in your local computer. If the firewall is enabled, make sure the Logos ports are open. You can test it by disable the firewall on local computer first.

 

On your local computer, go to the citadel local cache folder. It can be either Program Files\National Instruments\Shared\Citadel or Documents and Settings\All Users\Application Data\National Instruments\Citadel, depending on the Citadel versoin.

In the local cache, find the folder for remote server computer. Stop the National Instrument Citadel service, delete the cache folder and restart the service.

Deleting the cache folder sometimes fixes the exclamation mark problem.

 

By the way, is your local computer in the same subnet or same domain as the remote server? How about the "different computer" you said?

Ryan Shi
National Instruments
0 Kudos
Message 7 of 8
(5,587 Views)

I didn't try accessing the same database from the computer that works. It's a test I'll try if the firewall or cache tests don't work.

 

I just need to access the data. We have one main server for many projects where the data is logged, but every test bench is controlled locally. That is also where test bench operators create the traces or any data files they want through MAX.

 

All computers are on the same subnet.

 

I'll let you know when I get a chance to test this, but it might not be until monday.

 

Thanks for the help.

0 Kudos
Message 8 of 8
(5,579 Views)