LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

Why I cannot add the full DAQmx 8.0 in my distribution kit?

Hello,
I recently upgrade to CVI8.0, and I want to distribute my application (developed initially with CVI6.0 and successively updated). I would like to add in the distribution files the "full" DAQmx but I get a message "An unknown error occurred".
 
If I try to include DAQmx in a distribution kit generated from a NI example (i.e "WriteDigChan" or "WriteDigPort") I get the same issue.
 
I am using CVI 8.0 with DAQmx 8.0.0f0
 
 
Thank you
0 Kudos
Message 1 of 6
(3,640 Views)
Hello,

I would like you to follow the instructions in this post to generate a debug log file, then post that file back to this thread.  I assume the error occurr during the build of the distribution, not when you select DAQmx on the drivers and components tab.

Thanks.

Mert A.
National Instruments
Message 2 of 6
(3,635 Views)

Hello Mert,

thank you for your quick reply.

The message appears in fact when I build the distribution kit, not when I select DAQmx in the "Driver&Components" menu.

I followed your instructions on "WriteDigChan" example.

Attached you find the zipped log file and the .cds file (I don't know if something is corrupted on this file).

Thanks
 
baloss
0 Kudos
Message 3 of 6
(3,625 Views)
Hello baloss,

Sorry for the delay.  I have a couple steps to follow which should solve your problem.  Your issue is one we have been seeing occasionally because of the transition from our old parts to our new, deployment-enabled parts.  You have a new, deployable version of DAQmx that is declaring a dependency on an old, non-deployable MStudio patch, and this is causing the build failure.

First, I want you to re-run the NI Driver CD that came with CVI 8.0 -- you do not need to uninstall anything, just run it.  When the tree of features to install comes up, make sure you select DAQmx >> .NET Framework 1.1 Language Support to be installed, then proceed with the install. This should update the part causing the problems.

Now try building your distribution.  If it still fails, run the attached MSIBlast program.  This will show you every NI part installed on your system.  Find NI Measurement Studio for VS2003 Update 7.1.0.308 in the list, select it, and hit the uninstall button.  Now, repeat the previous step in which you re-run the Driver CD.

This should solve your problem.  If it does not, I will be happy to help further.

Mert A.
National Instruments

Message Edited by Mert A. on 02-02-2006 12:25 PM

Message Edited by Mert A. on 02-02-2006 12:26 PM

0 Kudos
Message 4 of 6
(3,606 Views)

Hi Mert!

I was ouside office for one week so I did't try your suggestion till today.

Following your instruction I tried to install .NET Framework 1.1, but did't work because the installer told me "Microsoft .NET Framework 1.1 is not present" and could not continue.

Then I used MSIBlast program to remove NI Measurement Studio for VS2003.

After uninstall, I created the distribution of "WriteDigChan" example successfully!

(After that, I tried again to re-run the NI Driver installation of .NET, still without success. However now the problem is fixed)

Thanks a lot!

baloss
0 Kudos
Message 5 of 6
(3,546 Views)
Hi baloss,

I'm very happy that you got everything working.  If you don't have the .NET framework on your machine, then there is no need for the Measurement Studio for VS2003 update, and removing it via MSIBlast is just fine.  I only suggested you try to update it from the CD in case you needed it.

Good luck!

Mert A.
National Instruments
0 Kudos
Message 6 of 6
(3,530 Views)