LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

x64 bit labview software toolkit

I am just wondering when labview plans to make a x64 bit toolkit for the LEGO NXT robotics system???

 

can anyone help me

 

because i have a x64 bit system and i want to program my robot using labview

 

thank you

Harold Timmis

Contract Engineer

ITD 

Harold Timmis
htimmis@fit.edu
Orlando,Fl
*Kudos always welcome:)
0 Kudos
Message 1 of 4
(2,065 Views)

Harold-

 

          Unfortunately I cannot comment on whether or not we plan to have a 64-bit toolkit for the NXT system. Currently the NXT Toolkit only support versions of LabVIEW 7.1 to 8.5. With only a handful of 64-bit drivers for LabVIEW period, i'm sure that will not be coming out soon if they are working on it at all. I have not consulted with our R&D department on this at all, but from what I know about 64-bit drivers, the best bet would be to find a 32-bit system. Sorry, I'm sure that this is not the answer you were looking for. 😞

Message 2 of 4
(2,033 Views)

I've got LabVIEW 8.2.1, 8.5.1, and 8.6 (all 32-bit) installed on my Vista64 machine.  Just because you have a 64-bit system doesn't mean you can't run 32-bit applications.  You won't get access to over 4 GB RAM that a 64-bit-native application could, but there's no need to get a 32-bit system just to run 32-bit LabVIEW.

 

Most of our drivers are compatible with 64-bit Vista for use with 32-bit applications, but I don't know for sure on the NXT driver.  I'll post back when I find out.

Message Edited by Jeff B on 02-11-2009 08:39 AM
0 Kudos
Message 3 of 4
(2,010 Views)

Ok, this was a little more complicated than I expected.  Here's what I've learned.

 

The NXT Driver that needs to be 64-bit in order to be used on a 64-bit OS does in fact have a 64-bit version.  Unfortunately, it is not included in the NXT Toolkit download available from NI's website.  I'm not sure if it is downloadable separately from LEGO or not.  It is included with the LEGO MINDSTORMS NXT 1.1 and later software.

 

I suspect that if you have LabVIEW 8.5.1 (32-bit) installed on a 64-bit Vista machine, and you then install the NXT Toolkit for LabVIEW 8.5.1, and finally install LEGO MINDSTORMS NXT 1.1 or later, the toolkit would work.  I have not tested this, however.

 

So you could try it (at your own risk - I wouldn't anticipate any problems beyond it perhaps not working, but can't make any guarantees), or find a 32-bit system as Grant suggested.  If you do try it, please post here with what you find.

0 Kudos
Message 4 of 4
(1,974 Views)