LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

tdms error 2500

Hi all,
I am experiencing a lot of errors (#2500) with opening and or reading from TDMS files in executables. The errors don't occur in the developer system. There is little use in including an example VI, even simple TDMS read executables seem to suffer the issue. Error 2500 is not defined, so I am somewhat at a loss.
Thanks for any suggestions!
AJ
------------------------------------------------------------------------------------
Seriously concerned about the Labview subscription model
0 Kudos
Message 1 of 7
(4,806 Views)
Hallo Aart-Jan,

could it be that it is related to this issue (error -2513)

Ton
Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
0 Kudos
Message 2 of 7
(4,796 Views)
I had a similar problem when I just updated to 8.2.1 (I updated 8.2 and I ran the simulation.msi fix). I fixed it by opening the project recompiling it (ctrl-shift click on the run button), doing a save all. Then rebuilding the project into an exe.

I'd guess that one of the tdms vi's needed to be recompiled.

Message Edited by Matt W on 04-11-2007 06:02 PM

0 Kudos
Message 3 of 7
(4,791 Views)
I'm currently investigating an issue that seems to be the same thing (CAR# 47TCG77Q). Error -2500 occurs when an application that was compiled with LabVIEW 8.20 runs on a machine that has the LabVIEW 8.2.1 RTE installed. That typically occurs if you install LabVIEW 8.20 and DAQmx 8.5 on the same machine. It works if you use LabVIEW 8.2.1 instead, it also works if you have DAQmx 8.3 instead of 8.5. I'll post more on this as soon as I have identified the root cause of the problem.

Sorry for the inconvenience.
Herbert

0 Kudos
Message 4 of 7
(4,789 Views)
By experience I can add to the equation that the issue also occurs running an executable with runtime 8.2 and build with 8.2.1
------------------------------------------------------------------------------------
Seriously concerned about the Labview subscription model
0 Kudos
Message 5 of 7
(4,773 Views)
On further investigation, there is not much good news. Unfortunately, we do not have a workaround for the incompatibility between the TDMS functions in the LabVIEW 8.2 and 8.2.1 runtime engines.

An application that uses TDMS and is compiled with 8.2 will only run with the 8.2 runtime engine. It will not work with DAQmx 8.5 (or higher) installed, since this updates the runtime engine to 8.2.1. The runtime engines for 8.2 and 8.2.1 cannot coexist on one machine.

If your application requires DAQmx 8.5 to be installed, the only way of getting things running is to compile your application with LabVIEW 8.2.1.

For the same reasons, an application compiled with 8.2.1 will not run with the LabVIEW 8.2 runtime engine.

Herbert

Message Edited by Herbert Engels on 04-18-2007 03:00 PM

0 Kudos
Message 6 of 7
(4,735 Views)


@matt W wrote:
I had a similar problem when I just updated to 8.2.1 (I updated 8.2 and I ran the simulation.msi fix). I fixed it by opening the project recompiling it (ctrl-shift click on the run button), doing a save all. Then rebuilding the project into an exe.

I'd guess that one of the tdms vi's needed to be recompiled.

Message Edited by Matt W on 04-11-2007 06:02 PM



Hi,
I think my TDMS pronlems are related to this issue.
With a LabView 8.2.1 upgrade + LabView 8.2.1 RT Upgrade + simulation.msi fix + LV 8.2.1 run time engine, I am still unable to get TDMS Open to work on my RT Controller. I will try the suggested solution of recompiling the project to see if that helps -> but I thought that the vi's were automatically recompiled if the version is not the same as the LabView version.
0 Kudos
Message 7 of 7
(4,625 Views)