LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

subvi call fails with built application but works OK with Development system

I have an application that runs fine when I am running the Development system. However, when I build the application into a compiled application and run it stand alone a subvi within the mail application fails and halts the program. I am running LV 8.6.

0 Kudos
Message 1 of 7
(2,512 Views)

You mention mail.  Are you using the internet toolkit?

 

How about attaching the VI or a screenshot of the error message?

>

"There is a God shaped vacuum in the heart of every man which cannot be filled by any created thing, but only by God, the Creator, made known through Jesus." - Blaise Pascal
0 Kudos
Message 2 of 7
(2,510 Views)
Sorry that is a typo. It should read main.vi.  The main vi is an extensive propriatory program.  I will attempt to capture a picture of the error message.
0 Kudos
Message 3 of 7
(2,505 Views)
So the error is labled "Null Window". Attached is a copy of the error message.
0 Kudos
Message 4 of 7
(2,497 Views)
Check your build settings and make sure that the build process is not removing the front panel from any subVIs for which you need to display the front panel.  Run a search on this forum for "null window" and you'll see lots more discussion on this error.
0 Kudos
Message 5 of 7
(2,485 Views)
One thing I screw up all the time is when I use "Current VI's Path" or the "Default Directory"... That can (and usually will) change when you build the executable.
-Matt Bradley

************ kudos always appreciated, but only when deserved **************************




0 Kudos
Message 6 of 7
(2,469 Views)
The null window was being caused by the fact that the Sub vi setup node did not match the front panel visibility setting in the subvi itself. Once I made these match the problem went away and I was able to get the compiled version to work. Interestingly, once I got it to work I was later able to manipulate the subvi setup node without adjusting the front panel visibility setting in the subvi itself.
0 Kudos
Message 7 of 7
(2,432 Views)