From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

shared libraries no output

Hi
 
I would like to know how to create dll from a vi.
 
I am using LabVIEW 8.20 and had tried using the Application Builder in the project but I cant seems to get it right. Hope someone will give me some advise.
 
I have attached the project and vis below. What I want to do is to create a dll for niScope EX Configured Acquisition.vi. However, I was unable to do it so I tried using part of that vi and named it Test.vi. I have connected in the Connector Pane for both inputs and outputs. After that, I go to the Application Builder and create a dll for Test.vi. However, when I go to Test Properties>>Source Files>>Define VI Prototype, I was unable to create outputs even when there are outputs in the vi. I also cannot add in input or output. May I know what did I do wrong or missed out??
 
Regards
Lee
0 Kudos
Message 1 of 3
(2,262 Views)
Hi ltok,

First of all, I was successful in making a shared library out of your niScope EX Configuration.

When I opened your Test.VI, I noticed that although you had wired some values in the connector pane of the VI to the right side, they were actually still indicators. In order to have the VI return some sort of value (and thus be able to change it in the VI prototype, you'll need to have some indicators connected to the connector pane).

Hope that helps.

Best regards,
-Sam F, DAQ Marketing Manager
0 Kudos
Message 2 of 3
(2,245 Views)

Hi Sam,

Ya I realise I make a stupid mistake. Thanks for pointing that out.

Regards
Lee

0 Kudos
Message 3 of 3
(2,236 Views)