Showing results for 
Search instead for 
Did you mean: 

polar plot scale numbers "truncated"

I have a strange problem when using the polar plot VI.

Labview 2012 latest SP, running on a cRIO9074. I'm running a servo motor for one revolution while measuring the runout on an armature using a linear position sensor.


The data looks good, but for some reason, the scale labels truncate after two decimals, no matter what I set the precision to. I'm sending it a cluster of two double precision arrays.


When I run the Labview example, it works fine I can change the number of decimals viewed to 10 if I need to. I've tried keeping everything the same as the example.


Any ideas?


See picture.



Polar Plot

The sample VI works fine, (I can set the precision to 6 and I will see 6 decimal positions. )



0 Kudos
Message 1 of 5

Hey Jeff,


That's definitely a strange issue. I have a few questions for you regarding this.


What Module are you using in you cRIO to measure this?

What example are you using?

I was not able to find a polar plot VI in LabVIEW, do you mean the Polar Plot with Points Options VI?

What how many decimal places does the data have coming in?

Are you using your data in the example?

Is the example running on your cRIO?

Is your VI based off the sample VI?

Finally, is this VI running on the cRIO?


Hopefully this will help us narrow down where the problem is occurring. 






Edit: one more question:


Was this ever working as desired? I.E., Was the VI functioning properly in a previous version of LabVIEW and it stopped function properly after LabVIEW was upgraded?

Kurt P
Automated Test Software R&D
Message 2 of 5

Thanks for the response, Kurt. With the help of a colleague, we were able to determine that this behavior is only when the VI is running on the cRIO.


(I think it was called "Polar Plot", but yes the VI is "Polar Plot with Points"


We verified this by running the example vi first from windows (works fine), then ran it on the cRIO. On the cRIO it truncates decimals depending upon what font size you use. If you use a REAL TINY font, it will include more decimals. When running in Windows, the graph appears to move left to accomodate for more decimal place. When running on the cRIO, it appears to cut the picture off on the right side.


Following is our setup, but as stated above, we sent the demo program to the cRIO (didn't use any I/O) and the problem occured.



We're using Labview 2012, latest updates applied.

Modules are:


NI-9411 to read an Ono Sokki position sensor (quadature output from two channels, resolution is .0001 mm.


Ethercat set up using the "getting started" manual for the NI supplied AKD servo drive and motor.


All hardware works fine and data collected looks good. Test is to turn motor and collect servo position and linear encoder position.

Data has 4 decimal places coming in.


0 Kudos
Message 3 of 5

Hi Jeff,


We'll set up a cRIO and see if we can reproduce the issue on our end.

Dave C.

Applications Engineer
National Instruments
Message 4 of 5



I just received a response from NI support and they confirmed that it was something in a low level VI when running on the cRIO.


I appreciate the responses, however, I don't want anyone to put more effort into this.


Thanks again!



0 Kudos
Message 5 of 5