LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

moving group ignores changes

I have a group in a tab container, I realise that there is a problem ungrouping in the tab control so I moved the group off the tab.
I made my change then grouped again but when I move the group the changes I made are lost and it reverts back to it's before the move/changes.

WTF?

Ron
0 Kudos
Message 1 of 3
(2,224 Views)
Hey Ron,

I tried to replicate this on my computer but I wasn't able to see the behavior that you saw.  Just to make sure I have the steps right here is what I tried. 

  1. Placed a tab control on the Front Panel
  2. Placed some controls and indicators on the tab control
  3. Grouped the controls and indicators
  4. Moved the group off of the tab control and Ungrouped
  5. Added a control to my group and regrouped
  6. Moved the group back to the tab control
Is this what you did?  Which version of LabVIEW are you using?  Could you provide a small sample VI that does do this behavior and any steps that I have wrong or left out? 

Thanks!
Andy F.
-----------------------------------------------------------------
National Instruments
0 Kudos
Message 2 of 3
(2,210 Views)
Here is what I tried:


  1. Placed a tab control on the Front Panel
  2. Placed some controls and indicators on the tab control
  3. Grouped the controls and indicators
  4. Moved the group off of the tab control and Ungrouped
  5. Changed the text of the caption on a few indicators
  6. Moved the group back to the tab control
  7. The text reverts back to what it was
Not sure but it might have something to do with the captions having the same name as indicators in another tab, the labels were different though. I went through and changed both labels and captions to something else then back again and now all is well. Just a Hiccup I think.

Ron
0 Kudos
Message 3 of 3
(2,203 Views)