LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

fft spectrum (mag-phase).vi: dependencies

Dear,

I'm having trouble using FFT Spectrum vi's. When I'm trying to add them to my vi, I get a 'Add to Project and Update Dependencies' error (see attached).

I can use the VI though.

Each time I open the project I keep getting the window to resolve the dependencies. When done, I save the project but the next time I have to start all over again.

Its like the settings aren't saved?

Can this be solved please?

Kind regards,

Ronny Comyn

Belgium

 

 

0 Kudos
Message 1 of 19
(1,997 Views)

Nobody can help please?

0 Kudos
Message 2 of 19
(1,982 Views)

Hello Mr. Comyn,

 

Can you share the project (and necessary files) you're using?

This way I can try to reproduce the issue at my side.

Kind Regards,
Thierry C - CLA, CTA - Senior R&D Engineer (Former Support Engineer) - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 3 of 19
(1,976 Views)

Hello Thierry,

 

enclosed the complete project.

Thanks for the help.

 

kind regards,

Ronny C

0 Kudos
Message 4 of 19
(1,970 Views)

Hello Ronny,

 

I could open your project without warning messages, but I seem to be missing at least one user lib you created:

PCI_USER_LIB

 

It could be that I'm not seeing the issue because of the missing user lib.

Can you share this with me?

 

Which version of LabVIEW are you using?

Kind Regards,
Thierry C - CLA, CTA - Senior R&D Engineer (Former Support Engineer) - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 5 of 19
(1,961 Views)

Library enclosed

 

kind regards,
Ronny

0 Kudos
Message 6 of 19
(1,955 Views)

Hello Ronny,

 

I don't seem to get this issue after I resave.

 

Could it be that you have 2 copies of these files available on your hard drive that are both in the "search path" of LabVIEW.

 

Here's my copy of the project in attachment.

Kind Regards,
Thierry C - CLA, CTA - Senior R&D Engineer (Former Support Engineer) - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 7 of 19
(1,942 Views)

Thx Thierry

 

I keep getting the same error, even with the adapted version. How can I know if I have multiple version of these files on my hard disc?

If you look at the errors (see enclosed), there are paths to SignalExpress and paths to LabView2011 directories, I don't know if this causes the error?

The VI's in the SignalExpress path have different names than the ones in the LabView2011 path, however.

 

Kind regards,
Ronny

0 Kudos
Message 8 of 19
(1,934 Views)

Hello Ronny,

 

Is this the only message you get?

Do you have any yellow exclamation marks in your project View?

Can you post a screenshot of the Project when it's opened?

 

Can you reproduce the issue by starting from scratch with a new project and adding your VI's?

 

 

Kind Regards,
Thierry C - CLA, CTA - Senior R&D Engineer (Former Support Engineer) - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 9 of 19
(1,930 Views)

No yellow excalamtion marks.

Screenshots enclosed

 

kind regards

Ronny

Download All
0 Kudos
Message 10 of 19
(1,922 Views)