LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

failure if acquisition in a loop with Keithkey2000

I encounter several problems with a K2000 Multimeter, during the acquisition of tensions on 4 different channels with Labview 7. The program uses the VI of the library of the driver of K2000 for Labview 7.The stages are as follows: 
1- Initialize 
2- Configure DC Volts: PLC = 10 
3- Configure Trigger: Source = Bus, Initiate = Continuous, Custom count = 1 
4- While loop containing a For loop of 4 iterations selecting the number of the channel by mean of a condition structure which contains: 
                           a- Configure Route Single: Close, n° channel 
                           b- Action send trigger 
                           c- Wait for 1000ms 
                           d- Data Read Single 
5- Close.
The list of the 4 channels is not an increasing list of consecutive numbers. 
Encountered problems: 
1- the execution stops after 5/6 measurements at Wait for RQS in spite of the time out of 25000ms.If I remove Wait for SRQ in Data Read Single I do not have this problem any more. 
2- the error -211(trigger ignored) appears at the beginning of the execution. If I choose don't reset in Initialize this error does not appear any more. 
3- if I apply a filter with Moving Average and 10 Readings, I obtain incoherent measurements and this, whatever are the values of the time delays introduced in Trigger and before Data Read Single. 
I read all documentation on the site of Keithley but I did not find a solution. So I need some indications especially for the third problem because I must imperatively filter measurements. 

I thank you for the assistance which you could bring to me
Sinou.
0 Kudos
Message 1 of 2
(2,081 Views)
Hi
I think that the problem can only be solved by your fabricant. He has developed the driver.

Kamal
NIF
0 Kudos
Message 2 of 2
(2,070 Views)