Showing results for 
Search instead for 
Did you mean: 

code 10 pci 6034e

Go to solution



I have a problem with my LabView and I'm running out of ideas how to fix it. In 2002 I designed a software for data aquisition based on LabView 6.1 using a PCI 6034E card. Since then everything was working fine. A few days ago I had to switch PCs.

I installed LabView 6.1 on the new PC. Afterwards I shut down the system, plugged in the 6034E and reboot the PC. Windows discovered the new hardware succesfully and installed a driver from the LabView Driver CD.


Unfortunately my device manager is telling me that the 6034E is producing a Code 10 error. Until now I have tried to install the newest driver from NI, reinstalling LabView and the drivers multiple times.


The only difference I could encounter betweed the two PCs is that the old PC is operated with Windows XP SP 2 and the new one uses SP 3.


Do you have any ideas what could cause the problem?


Best regards,


0 Kudos
Message 1 of 4

Hello Theodor,


Is it possible to send me a screenshot of the error Code 10? 


But first try to instal this version of the DAQmx Driver,


The DAQmx Driver in this link includes the right version of the NI-PAL Driver which is the reason for this error Code 10 (in the moste cases).


Best regards,



0 Kudos
Message 2 of 4
Accepted by topic author mouthbag

Hello Tobias,


thank you for your reply. I already tried installing the DAQmx 7.0 yesterday evening. It worked fine with the PCI 6034E. Unfortunately I couldn't use my programm any more, because some sub vi are incompatible with DAQmx above verson 6.9.3.


However, I managed to solve the problem. There might have been a comflict between the PCI 6034E and the computers video card. I deaktivated the videocards PCI port in Bios and switched to on board graphics. Then I uninstalled all National Instruments software, for a fresh start. After a reboot, video card still disabled, I installed LabView 6.1 and DAQ 6.9.3. After inserting the PCI 6034E now, everything went flawlessly. Windows recognized the card and installed the drivers. According to MAX the card works fine and my programm is also running.


After this I enabled the video card again, via bios. Still everything is working fine. I can't tell you how the video card could have caused the trouble, but one should keep this in mind for the future.


Best regards,


0 Kudos
Message 3 of 4

Hello Theodor,


Thank you for your fast reply.


Sounds good that everything is working well now. 

This is a new kind of problem I have never heard about, but thank you for sending me the solution of this case, i will keep this in my mind for the future.


Best regards,


0 Kudos
Message 4 of 4