Showing results for 
Search instead for 
Did you mean: 

cant insert subvi

I dont know what I did, but I can no longer insert a vi into a vi when I select "select a vi" from the functions palette (or any other way.)  When I do this the open vi window opens and I can select a vi to insert, but when I hit ok the current vi's window blinks twice and the vi i selected isnt inserted.  What did I do?

0 Kudos
Message 1 of 6

Did you try another VI?


If the VI you are trying to insert is corrupted, that could explain the symptoms you described.



Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 2 of 6

I've tried other vi's.  I've tried making brand new, simple vi's. I've tried restarting the computer...

0 Kudos
Message 3 of 6

Does LabVIEW ask you to investigate the error at startup? Or, did you turn that option off (it's in the "Debugging" section of the LabVIEW options). Did you get an error log (it should be in your "LabVIEW Data\lvfailurelog" in your personal Documents folder)? Have you tried to do a repair on the LabVIEW installation?

Message 4 of 6

Is the file write protected? (brainstorming)


G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
0 Kudos
Message 5 of 6

What version of LV are you using? What kind of license (Base, Full, Professionell)?

Does this also happen when placing VIs already available on the function palette like e.g. "Write to Spreadsheet" in the File IO palette?



CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 6 of 6