LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

about vi close

Click A button on A.vi to run B.vi.

If you press the exit button on B.vi you can return to A.vi

but you can see UI on A.vi, but nothing is pressed.(If you click the buttons on A.vi that  it don't work.)

 

What do I need to set up in Call Setup or subvi node setup?

what is the reason?

0 Kudos
Message 1 of 4
(1,286 Views)

This sounds like it is related to yesterday's thread

Re: I have a problem about SubVi Run

 

Since you started a new thread, I guess I can assume you resolved yesterday's issue and have a new one.  But just like yesterday's problem, it is very difficult for someone to help you debug a VI that you failed to attach.

 

So attach your newest VI's.

0 Kudos
Message 2 of 4
(1,278 Views)

Attach your code!

 

How is B configured? (Modal? Open when called and close afterwards? Node setup? Is the panel of B closed before you run A? Etc.)

 


@adavb wrote:

...but you can see UI on A.vi, but nothing is pressed.(If you click the buttons on A.vi that  it don't work.)


No, we cannot "see" anything! Here you are describing a behavior, but you are not even telling us if you want ot don't want this.

0 Kudos
Message 3 of 4
(1,253 Views)

If you are running B as a subVI, A can not continue untill B finishes, basics of data flow. Call setup or subVI node setup do not matter. 

To start B and allow A to continue you can use VI server tools: open reference to B and then use either

a) Run VI method

b) Start asynchronous call

0 Kudos
Message 4 of 4
(1,186 Views)