LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

This Program can't start because dll is missing from your computer

My lab had a software on the old computer with windows 7, labview 8.5.1 and it worked fine. We got a new computer recently with windows 10 system and I have tried all the Labview versions, 64-bit or 32-bit instruction set and have tried all kinds of patches. However, there are still two problems:

1. as my title said, it says that I am still missing some library files.

2.Call library function node are failed to load or open(I made sure that in my user.lib I included all the dlls needed. Also I placed the license file into my labview folder). Since We got it from another company, we can't get into their block diagrams so I am unable to check the call library function node either.

 

Does this just mean that my license file is not right? What can I do about it?

0 Kudos
Message 1 of 4
(4,449 Views)

What DLL? Is it a LabVIEW DLL or a DLL from a third party?

 

Now I am just grasping at straws here but... Most DLL's have to be "registered" in Windows, so it knows where to find them (I think). This is usually accomplished during installation by an installer program. Just copying a DLL to a new computer rarely works. You can manually register a DLL, but you will have to Google that as off the top of my head I can't remember how.

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 2 of 4
(4,437 Views)

Which DLL is missing? Is it a third party provided DLL?  How did you install the software? (Please tell me the author provided an installer!)

 

Is this source code with the vi BDs locked or an executable?  By All LabVIEW versions what do you exactly mean?  Which ones and did you mean the run-time engines or the IDEs?

 

You did say "This Program" so... I'm going out on a limb and thinking you need some NI driver support that is compatible with 8.5.1.  Again, as suggested by RSTLVU and myself, did you have an installer (Note 8.5.1 is not officially supported on Windows 10)


"Should be" isn't "Is" -Jay
0 Kudos
Message 3 of 4
(4,432 Views)

Hi zt1217,

 

I have a few more questions I would like to ask to better assist you:

1. Are the missing .dll files apart of your LabVIEW installation or are they ones you are providing to your code that it is having an issue reading?

              - If so, what error message are you getting?

2. Does the call library function give us an error code there? If so, can you copy and paste the message? 

3. License files don't like to be moved. The easiest way to deal with them is usually to save a copy of it somewhere, delete it, and try to reactivate the product. 

 

 

Chase
NI Technical Support Engineer
0 Kudos
Message 4 of 4
(4,350 Views)