LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Taking a fft of a audio signal

Thanks for reading my post!

 

I have a program attached here that is supposed to take a fft of a audio signal coming in from the the computer. Its connected in the mic in jack. Could someone check out the program and tell me what it is missing cause it doesn't quite give you the right graph. Also, the y range is supposed to be in volts but it stays as amplitude, I don't know why. Any help would be appreciated.

 

Thanks in advance

 

Moe

0 Kudos
Message 1 of 31
(2,904 Views)
0 Kudos
Message 2 of 31
(2,899 Views)

 

Could someone check out the program and tell me what it is missing cause it doesn't quite give you the right graph.


What's wrong with it, in other words,what do you expect it to do that it doesn't?

 


Also, the y range is supposed to be in volts but it stays as amplitude, I don't know why. Any help would be appreciated


So what happens when you manually change it (Double click on the label "amplitude" and type Volt there instead) ?

0 Kudos
Message 3 of 31
(2,870 Views)

It suppose to give me a fft graph, which is frequency on the x domain and Volts in (rms units) on the y range. how could you calculate the rms?

 

Thnxs

0 Kudos
Message 4 of 31
(2,857 Views)
Since you are already using all Express VIs, why did you decide to do your own fft and not use the Spectral Measurements Express VI?
0 Kudos
Message 5 of 31
(2,857 Views)

What I think you want, is what the "Auto Power Spectrum VI" does, on my computer it's in "signal processing-> Spectral analysis".

 

You still have to manually edit the axis labels. The graph doesn't know what these numbers are that you are connecting to it. To it, it's just an array of numbers. Though Labview is rather smart compared to other programming languages and development environments, it´s not all magic Smiley Wink. Some things require the programmer (you) to program some more. 

 

Quite often, the RMS value is "calculated" by just taking the normal value and deviding by the square root of 2 (1.414). I wouldn´t know how else to do it in a spectrum.
0 Kudos
Message 6 of 31
(2,852 Views)

I'm not.. could you look at my code and see what I have to do. This is the first time working with fft and i've only being coding on labview for 3 weeks.

 

Thanks in advance

0 Kudos
Message 7 of 31
(2,858 Views)

Hi jacco

 

Thnxs for the response. Where do I put the auto power spectrum in my code.

 

Thnxs in advance

0 Kudos
Message 8 of 31
(2,856 Views)
The Express VIs are designed for people like you that are not experienced in LabVIEW programming. Just try it.
0 Kudos
Message 9 of 31
(2,853 Views)

it's still not giving me the right graph. I have a DSA reference and the y range is going from 10uVrms to 10Vrms.

 

Thnxs a lot 

0 Kudos
Message 10 of 31
(2,851 Views)