LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Still gettting error 33162 despite increasing network timeouts

Hi All,

 

I have an application that frequently displays error code 33162.  I followed the advice at http://digital.ni.com/public.nsf/allkb/C4E77D7E9BECBAFE86256C6200544289 and doubled my network timeouts to 4 seconds timeout and 10 seconds initial connect timeout.  I still get the error however.  When I get the error the block diagram briefly flashes on one of the blocks, but it's too fast to really see.

 

Any advice on how to solve this error condition?

 

Thanks,

Sean

0 Kudos
Message 1 of 7
(3,610 Views)

Hi Sean,

 

What hardware do you have?

 

Are you able to read from the channel in Measurement and Automation Explorer?  

 

Have you tried adding error handlers?

 

Can you attach your code, or a screenshot of it?

 

Best Regards,

Bryan H.
0 Kudos
Message 2 of 7
(3,567 Views)

Hi,

 

I am having the problem occur repeatedly again today.  My fieldpoint hardware is cFP-2000.  I am currently seeing repeated 33162 errors, so many that I have to stop my application.

The attached screenshot shows where the error is occuring.  We'd really appreciate any advice on this problem.  Our fieldpoint modules are located close to some heavy AC equipment, so hopefully the EM fields from this are not affecting them.

 

Thanks,

Sean

 

 

 

 

0 Kudos
Message 3 of 7
(3,535 Views)

Hi Sean,

 

The user manual lists the electomagnetic compliance on page B-4 (64 of the pdf).  Have you tried moving your FieldPoint controller away from the heavy equipment?

 

Best Regards,

Bryan H.
0 Kudos
Message 4 of 7
(3,517 Views)

It turns out that the fieldpoint modules I was looking at where not the ones giving the error; the ones that lead way to error 33162 are well shielded.  Is there any diagnostic we can run to check communications to the Fieldpoint module e.g. to test cabling and network reliability?  We still are getting this problem intermittently.

 

Thanks,

Sean

0 Kudos
Message 5 of 7
(3,510 Views)

Hi Sean,

 

I found another Discussion forum where someone else was experiencing a similar problem.  Does that help?

Bryan H.
0 Kudos
Message 6 of 7
(3,490 Views)
Thanks for the responses. It turned out the problem was a fieldpoint module being in a bad state and unable to communicate.  Resetting the fieldpoint module fixed the problem; no more 33162 error.
0 Kudos
Message 7 of 7
(3,476 Views)