LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Rare USRP error : Possible reason(s): The local oscillator did not lock within the allotted time.

Dear friends, 

 

This question gotta be kinda hard to explain, because I am not allowed to attach my project here:( 

I got an error :

 

Error -1074118626 occurred at niUSRP Write Tx Data (CDB Cluster).vi
 Possible reason(s):
The local oscillator did not lock within the allotted time.   

 

The vi is just a transmission vi, using usrp 2953. If I use channel 0, then the vi can run without any error.  But If I switch to channel 1, I got the error.  Btw,  switching channel 0 or 1, will NOT change any other parameters, such as carrier freq, gain, ........no parameters will change because of channel selection. 

I tried google this error, I only found one person ask this, but his problem was not solved neither......   Anyone can lend me a hand about this?   Thank you! Thank you!!!!

0 Kudos
Message 1 of 5
(2,093 Views)

Hi sunson,

 

Do you get this every time you try and use RX1 on this unit, or only sometimes? If you haven't already, definitely update to the newest USRP driver (17.0 I believe). You could also try dropping a USRP Property node and configuring the Reference Frequency and Timebase Clock source to Internal explicitly, I've seen the GPS enabled USRPs sometimes try and grab the GPS clock even when it's not specified. This would ensure you're using the internal source. Although now I realize you didn't specify, are you trying to run off the internal clocks? Or is this supposed to sync to an external source, either from another USRP/device or the GPS?

 

Cason

NI Applications Engr.

Cassandra Longley
Senior Technical Support Engineer - FlexRIO, High Speed Serial and VRTS
0 Kudos
Message 2 of 5
(2,054 Views)

Hi,Cason,  

 

Thanks for your help. I am using a PC to control multiple usrp with a switch.  I dont think I am using anything GPS (at least not intend to:)). Where to find out I am using external clock or pc clock, btw???  

Yeah, I do try to delete the property node, but I still got error.  Btw, the only property node is the node for switching channel.  

Yes, I got the error everything time, as long as I use channel 1, error;  channel 0, no error.....  

0 Kudos
Message 3 of 5
(2,050 Views)

So to be clear, I'm suggesting you do drop down a property node and explicitly configure the clocks. You can use the same node to check clocking ad you can use to set it: USRP Property Node - Clocking and Synchronization - Reference Frequency source or Timebase Clock source are the specific properties you'd want.

 

Cason 

Cassandra Longley
Senior Technical Support Engineer - FlexRIO, High Speed Serial and VRTS
0 Kudos
Message 4 of 5
(2,043 Views)

Thank you very much.  I will check more. 

0 Kudos
Message 5 of 5
(2,040 Views)