Showing results for 
Search instead for 
Did you mean: 

Problem on placing and find VI on Labview help

In LabVIEW help, the link buttons of "Place on the block diagram" and "Find on the Functions palette " do not work. I mean, I can not place a required VI on the block diagram from the help windows using the "Place on the block diagram" button. Also I can not find the VI using the "Find on the Functions palette " button.

I exacly floowed the installation guides of the software. COuld you please tell me why this happen? Thank you very much.

Message 1 of 21

It's possible that the VI you are trying to place is not available in the LabView package that you have.
For instance "1D Polar to" is not available in the Base Development Package. The title at the top of the help page will indicate this.
Try accessing the help page for a simple VI like "Add" and see if you get the same problem.
Hope this helps.

0 Kudos
Message 2 of 21
I have the same problem with any function from the help screen in Labview 7.1. The Find and Place on block diagram just doesn't work. I have the full blown Labview edition with everything and more. I can't get simple functions like add to be placed on the block diagram. It works fine in Labview 7.0, but not in 7.1.
- tbob

Inventor of the WORM Global
0 Kudos
Message 3 of 21
I tried to place/find from the help and it didn't work for me either. I don't normally work with the function palette visible at all times. I just right click when I want something. However, I first made the palette visible and tried place/find again. This time it worked. It appears that NI changed the behavior or there's a bug in that help fails to open the palette when it's not already visible.
0 Kudos
Message 4 of 21
I made the palette visible, but when I open the help screen, the palette becomes hidden. It only becomes visible when I click on the block diagram. So when I go to the help screen to click on Place on block diagram, the palette is automatically hidden. Dennis, don't you use LV 7.0? It works fine with 7.0 here. It is only with 7.1 or 7.1.1 that I have this problem, and evidently so do others. Not that it bothers me since I would rarley use the Place of Find buttons anyway.
- tbob

Inventor of the WORM Global
0 Kudos
Message 5 of 21
No, I actually use 6.1, 7.0, and 7.1. Haven't installed 7.1.1 yet. I to see the palette hidden when I go to the help menu and then reappear when I click the diagram. The hand tool then has the function I've chosen to place. It doesn't really bother me either. Until this post, I don't think I had tried in quite a long while.
0 Kudos
Message 6 of 21
Maybe the problem is with 7.1.1 only. I don't remember trying this with 7.1 before I installed the 7.1.1 patch. If you ever install 7.1.1, you can try it again to see if it stops working. I would be interested in knowing if my problem is local.
- tbob

Inventor of the WORM Global
0 Kudos
Message 7 of 21
My experience sjowed no problem with V7.0 but does occur on V7.1 which I am using now. So, looks like it is a bug for V7.1.

Hope NI tech. will show us how to solve this problem.
0 Kudos
Message 8 of 21

This is a problem seen with LabVIEW 7.1 (with or without 7.1.1 patch) on Win XP machines running SP2. LabVIEW R&D is aware of the problem and is working on fixing it in future releases of LabVIEW.

Thanks for your feedback.

Ankita A.
National Instruments
0 Kudos
Message 9 of 21
In principle there is a workaround for this problem.

  1. Decompile the glang.chm file (using HTML Help Workshop).

  2. In helpserver.js change the loopback IP addresses from to and them recompile.

  3. Repeat for other CHM files where the placing and find VI problem exists.

This enables the “Place on the block diagram” and “Find on the Functions palette” buttons, but you lose the scrollbars from the table of VI/function parameters etc. Obviously there are no guarantees with this kind of approach and I accept no liabilities, but applying this hack to glang.chm worked for me.
0 Kudos
Message 10 of 21