LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI9145 error while switching to active mode

Good morning,

I have four NI9145 modules connected in daisy chain to a CRIO 9048 and to other EtherCAT slaves. When I switch the Scan Engine from configuration mode to active mode, all the devices in the Ethercat chain go to operational state, except from one NI9145 module, which goes to error and stays in safe operational. The error message that the device provides is the following:

 

Error -2147137766 occurred at an unidentified location

Possible reason(s):

NI-Industrial Communications for EtherCAT:  Timing monitors have detected a synchronization or timing error.

 

If from the safe operational state I manually move to operational state, the error goes away, and the modules attached to the NI9145 can be accessed normally.

If it is useful, the NI9145 that goes to error contains only digital output modules NI9472, and it is the second device in the ethercat chain (before that, there are the CRIO and another NI9145 module).

 

Does anyone know what could be the problem? Please let me know if you need more information.

 

Thanks and best regards,

Lorenzo

0 Kudos
Message 1 of 3
(698 Views)

What happens if you switch the 9145 to a different order in the daisy chain? Or switch the 9145 with another one? Does the error follow the chassis?

 

Can you  try formatting and reinstalling software on the problematic chassis?

0 Kudos
Message 2 of 3
(658 Views)

Thanks for your answer!

I did not need to change the order of the NI9145 devices. The cause of the problem apparently was the connection to a Beckhoff CU1128 Ethercat hub further in the chain. The daisy chain of the NI9145 devices was connected to this hub, and by changing the order of the connections to the hub the problem seems to have disappeared.

0 Kudos
Message 3 of 3
(636 Views)