Showing results for 
Search instead for 
Did you mean: 

NI_AALPro.lvlib Missing on Target PC

  1. Clean install of LV2011 with Windows 7
  2. Created an executable and installer.
  3. Application Builder loaded Lvanlys.dll to “support Files” directory
  4. Installer installed properly.  When the program runs, the following error is shown:

  NI_AALPro Error.gif



  1. After lots of troubleshooting, I got the program to work by deleting Lvanlys.dll.  But the following display is shown each time the program runs (scaring my customers). 

 Loading Error.gif


Please advise how I can properly place/link to this dll so that it loads without displaying the window shown above

0 Kudos
Message 1 of 10



NI_AALPro.lvlib is associated with the Advanced Math and Signal Processing Toolkit. Try rebuilding the installer. When you do this go under the Additional Installers category in the My Installer Properties Window and include the Advanced Math and Signal Processing Toolkit. Let me know if this solves your issue.




Josh Brown

Applications Engineer
National Instruments
0 Kudos
Message 2 of 10

Josh - Thanks for the reply.  I wasn't able to find the "Advanced Math and Signal Processing Toolkit".  There's an "Advanced Signal Processing Toolkit" but it's only for 2009 and previous versions.  Is this the one you're referring to? 



Additional Installers.PNG



0 Kudos
Message 3 of 10



I apologize about that. Yes, let’s try the Advanced Signal Processing Toolkit and see if that works. 




Josh Brown

Applications Engineer
National Instruments
0 Kudos
Message 4 of 10

I included the Advanced Signal Processing Toolkit and still got the following error when I ran the program:




I got the program to work by replacing the lvanlys.dll (01/13/2011) file in my "Support Files" directory (installed at the same level as my executable) with the lvanlys.dll file dated 06/22/2011 from the folder: C:\Program Files\National Instruments\Shared\LabVIEW Run-Time\2011


Are there any explanations why this might be happening?  The lvanlys.dll file has been included in the build regardless of the Advanced Signal Processing Toolkit, so I don't think I have to include the Toolkit in future builds.  I could add the lvanlys.dll (06/22/2011) file to my project and explicitly add it to my support files folder but I would like to know more about what's happening before I start messing with the complied structure.  Any suggestions?



0 Kudos
Message 5 of 10



When you created the executable did you include all of your dependencies within the Always Included section of the source files tab?




Josh Brown

Applications Engineer
National Instruments
0 Kudos
Message 6 of 10



I think this ended up as my fault.  I switched recently from LabVIEW 201o to 2011.  When I compile the executable, I  save it to an intermediate folder location from the one that I use to create the installer.  LabView created the lvanlys.dll (01/13/2011) version in 2010 and the lvanlys.dll file dated 06/22/2011 in LabVIEW 2011.  I didn't move the latest version to be included when I built my installer.  But thanks for your help with this...


0 Kudos
Message 7 of 10

Hi all...


I just had a similar problem.  Starting the executable, the error message that NI_AALPro.lvlib's

front panel cannot be opened, mentioning Linear Fit Coefficients, appeared.  Several other

similar error messages also came up.


The funny thing is that if I run the program from the My Documents folder, it works fine.

Running it from I-V Software folder inside My Documents, I get this error.  Yes, the files

are identical.  I even tried putting copies of the dll files all over the place so the programs

could not avoid finding them.


These programs are written in LabVIEW 8.5.  The LabVIEW 8.5 Runtime Engine was installed

separately and also from the program installer.  But, it doesn't appear in the list of programs

that can be uninstalled.  Trying to install it again, it says it's already there, even after I have

deleted all the runtime engine files in C:/Programs/National Instruments/Shared/LabVIEW Runtime.

One of these fora provided the program msiblaster, which was able to find and uninstall

the various versions of the Runtime Engine that were on the computer.  Then, after installing

the 8.5 Runtime Engine again, it had the same problem.  


Reading this and other threads in these fora, I decided to look carefully at the Installer

configuration.  I created the folder I-V Software in the installer and told it to put the program

and the dlls there.  Somewhere in these fora it says to include the math toolkit or the signal

processing installer, but neither of these were available in the installer configuration.


But somehow, it worked.  After I ran the installer, the program now runs from inside the I-F

Software folder like it's supposed to.  But why?


From the manufacturing standpoint, it's much easier to have the assembler prepare the computer

with the LabVIEW 8.5 Runtime Engine on it, then copy the customer-specific program onto

the customer's computer.  I would rather not have to make a new installer for each customer

(each customer's software is unique) and have the assembler run the installer.  It's so much

easier to just build an executable and have the executable added to the customer's computer.

We've done it this way for years and now it stopped working, possibly correlated to using a

more-recent version of DAQmx.


Could anyone comment on why this is happening and if there is an easier way?




0 Kudos
Message 8 of 10


I got the error similar that you got. I build my distribution kit, install on 5 differents PC and 2 on those have this issues. I use LabView 2010. All PCs have the same software configuration, but diffrent hardware (CPU, memory...)


Hope for some any idea soon!


0 Kudos
Message 9 of 10

Using LabVIEW 2012.

using an installer.

I use several data analysis VIs.

The installer correctly creates a data folder with lvanlys.dll.

I get an a string of errors when loading the application that are similar to the errors that others have gotten on this thread.

The computer that is using the installer is a Dell xps ultrabook.

I'm using Windows 7 Enterprise 64 bit on both development machine and deployed machine.

Any ideas why the executable can't find the code in the lvanyls.dll?

0 Kudos
Message 10 of 10