Showing results for 
Search instead for 
Did you mean: 

Missing Robotics Module

Hello everyone!

The Robotics module is missing from the Functions main pallette, although when I look up examples that has robotics Sub-VI's, they appear normally with no errors, when I try to look up their pallette, they are no where to be found.

I tried repairing the module, uninstalling and re-installing it, even uninstalled labview as a whole and reinstalling it and installing the module afterwards, while restarting my laptop in between steps, still no Robotics module pallette.

Any help please? 



0 Kudos
Message 1 of 7
Ok, start with
- what is your os version and bit?
- what version of LabVIEW installed?
- did you check in NI license manager and see it is existing and licensed?
- it was present earlier or is it first time you installed?
- does the palatte heading shows or not?
- possible to post screenshot of function palatte?
- I hope you know how to show or hide palette( sometimes we miss silly things😋)
0 Kudos
Message 2 of 7

Thanks for the reply! ... Alright, so

- Windows 10, 64 bits

- Labview 2015 32 bits

- Yes i did, It's activated ( Both Labview and the Robotics Module )

- It used to work back when I had Windows 7. 

-I'm not sure what do you mean by a palette heading tho.. can you explain?

-The functions palette is in attached Image 3
-Also, from attached image 1, the robotics module logo doesn't show up next to the rest.

Download All
0 Kudos
Message 3 of 7
In function palatte when you click change visible palette it will display all the modules installed, robotics module is displayed there?
- when you open the robotics example vis you mentioned no problem means vis exist but only not visible in function palatte am I right?
- palatte heading I meant as like " Vision and Motion" , " Mathematics".
- try this : Icons
0 Kudos
Message 4 of 7

-Robotics module is not displayed in the change visible palette either.


- Attached you can find a screenshot of the robotics example, when I right click one of the robotics sub-vi's ( which works fine ), and try to replace it, Labview should suggest the Robotics module palette for me automatically, but it doesn't. As if Labview doesn't know it's installed.


- I just tried the link, doesn't make a difference unfortunately.


Any other suggestions?


0 Kudos
Message 5 of 7

I believe the Robotics Module supports devices and sensors connected to such NI platforms as Compact-RIO, Single-Board-RIO, and myRIO, with LabVIEW development taking place through LabVIEW Project with one of these Targets as the targetted Deployment site.


Is that how you have your code set up?  Do you have a LabVIEW Project created?  Note that it really helps us to understand the nature of your problems if you attach LabVIEW code (VIs, Projects, .ZIP files created by compressing the folder where your code and auxilliary files are contained).


Bob Schor

0 Kudos
Message 6 of 7

In the functions palette, search for a VI you know exists in the robotics module.  Is it found?

0 Kudos
Message 7 of 7