Showing results for 
Search instead for 
Did you mean: 

Memory Full Error everytime i run my VI

I have been getting a memory full error everytime i run my VI. I did'nt get this problem until a few moments ago and have executed the vi successfully before. I have included the VI, is there anyway to clear the memory? (I tried restarting the computer with no luck). Am I making some sort of mistake?

0 Kudos
Message 1 of 4

It would help if you specified that you're talking to a piece of Keithly equipment and the VI you posted needs it's instrument driver.  Also, what are the values you're using in the front panel?  All the default values for the numerics are 0 and I'm sure that's not what you're using when you run the VI.

0 Kudos
Message 2 of 4

I am running sweeps of 0 to 5 in 0.05 increments and 1 to 3 in increments of 0.1 giving a total of ~2000 items in the array.

0 Kudos
Message 3 of 4



I can't run the vi, so I'll make a few general suggestions.

In the inner loop you are using auto indexing to build arrays. Each iteration thus creates a buffer for two arrays (check tools -> profile -> buffer allocations). Initialize these arrays outside the loops with the size you need. Then use shift registers and replace array element to use the same memory over and over.

LabVIEW needs continuous chunks of memory to store arrays, once your memory is sufficiently fragmented by allocating buffers over and over you may run out of space although task manager shows enough free memory.




0 Kudos
Message 4 of 4