From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview FPGA Error - Urgent Please

Solved!
Go to solution

Hello,

 

I have been experiencing this problem for a while and it is driving me crazy. When I try to program my Spartan 3E fpga board, I get a message, it compiles successfully. Then I get an error stating that

 

"Labview called another software component and that componen returned ther following error:

 

Error Code = -2147483648

 

Error -2147473648 occurred at nilvcseInitChain.vi

 

This error is undefined. No one has provided a description for this code or you might have wired a number that is not an error code to the error code input."

 

Please Help!!!

0 Kudos
Message 1 of 14
(4,079 Views)
Solution
Accepted by topic author eceone

1.  What version of LV are you running, 8.5 or 8.6?  What operating system are you using?  XP, Vista (32/64-bit?)

2.  Go to Device Manager (right-click My Computer/Hardware tab).  Do you see a category called "Programming Cables" and is the Xilinx board listed under it?

 

reid

Message 2 of 14
(4,071 Views)

Hey,

 

Is this just comeing up with your VI or with any VI you compile?

This might be a problem with the board itself. Are you able to test another board or FPGA hardware?

 

Christian

0 Kudos
Message 3 of 14
(4,069 Views)

I'm running labview 8.5. I installed the module on my desktop months ago and it worked perfectly. Then, I installed the module on my laptop and I can't seem to get it to work recently.

 

I really hope it's not my board because i can't afford to get a new one anytime soon.  I use the board for other verilog programming and it works fine. I even successfully wrote  a xilinx verilog module on my board last week.

 

I don't know what to do. I need this to work for my senior project.

 

Thanks for your help.

0 Kudos
Message 4 of 14
(4,053 Views)
I have tried various VIs and even some examples provided by NI and still no luck.
0 Kudos
Message 5 of 14
(4,051 Views)
Did you check Device Manager and make sure the device shows up under Programming Cables?
Message 6 of 14
(4,049 Views)

I haven't done that yet. I'd do it and let you know if it works.

 

Thank you for your help.

0 Kudos
Message 7 of 14
(4,047 Views)
 
0 Kudos
Message 8 of 14
(4,007 Views)
Thanks, it works fine. Apparently the xilinx usb cable was not properly configured.
0 Kudos
Message 9 of 14
(4,004 Views)

Hi,

 

I am getting the same previously defined error. The xilinx cable is configured properly. the fpga works fine. I don't know what to do. I am using Labview 8.5 with Windows XP. Please help.

I am frustrated already.

 

thanks

0 Kudos
Message 10 of 14
(3,868 Views)