LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LABView 2015 - Linux - Distros?

Hello!

 

I was wondering if it is possible to use LabView 2015 SP1 as development system on Linux and got "confused" by mismatch between Downloads page and ReadMe page for Linux:

  • The ReadMe page in section of System Requirements clearly implies existence of Development environment for Linux
  • The Downloads page contains for 2015 SP1 only Runtime Engine installer
  • However, if select 2015 SP1 Patch, it shows that included editions are Full and Professional, which also implies existence of installer for development environment.
    This part also has a  note "Please install LabVIEW 2015 SP1 (64-bit) before installing this patch."

So, it there a installer of Development system for LabView 2015 SP1 on Linux or not? If yes, where to get it?

 

0 Kudos
Message 1 of 4
(798 Views)

Hi Ye,

 

the download page only offers to download the "full IDE" starting from LV2018…

 

The questions are:

  • Why do you need such an old LabVIEW version?
  • Why don't you have a backup of the installation files on your own server when that version is so important?
  • Did you ask NI support for a download link?
Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 2 of 4
(791 Views)
  • FieldPoint compatibility
  • It happened so
  • I was asking if such thing exists
0 Kudos
Message 3 of 4
(785 Views)

LabVIEW for Linux and Mac before 2018 had no license control whatsoever. As such the download never has been available to anyone but people who could proof to have a valid license. You need to contact NI support with proof of purchase to get such a temporary download. And yes it's going to be temporary. You get a link and the according file will be removed from the servers after some time, usually a few days.

Rolf Kalbermatter
My Blog
Message 4 of 4
(766 Views)