LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Keithley Nanovoltmeter Model 2182A and RS-232

Hello!

 

I have a Keithley Nanovoltmeter Model 2182A and RS-232. I need to build a simple code to read, store and build graphs from the nanovoltmeter data.

 

I configured the 2821A as per the manual and data.

Here is the configuration of the RS232 of the 2182:
baud rate: 9600
Flow control: none
TX Term: CR

Here is the configuration of the with port of the program:
baud rate: 9600
stop bits: 1
date bits: 8
parity: none
Flow control: none
TermChar End-of-String for receiving: CR
TermChar End-of-String for sending: CR

 

Even though I made the settings and changed the port on the instrument, I got no response.

Are there any specific labview drives for communicating via RS-232? Looking on the site I found only this one for GPIB.

 

"LabVIEW Plug and Play IEEE 488.2 (GPIB)"
http://sine.ni.com/apps/utf8/niid_web_display.model_page?p_model_id=5340

 

One of the errors he got in one of the configuration attempts was ERROR 85.

0 Kudos
Message 1 of 3
(1,450 Views)

Hi Lucas,

 


@HarleyLucas wrote:

Even though I made the settings and changed the port on the instrument, I got no response.

Are there any specific labview drives for communicating via RS-232? Looking on the site I found only this one for GPIB.

 

One of the errors he got in one of the configuration attempts was ERROR 85.


  • For RS232 all you need is VISA - and a COM port on your computer, either real hardware or virtual over USB…
  • Error 85 is an "unexpected string at ScanFromString function" error: this means you either receive no data at all (where you should get a timeout error instead!) or you receive some data, but not in the expected formatting…
  • To get more detailed help you should always attach your code…
Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 2 of 3
(1,416 Views)

Thanks for the answer.

 

I tried running to do some reading. Got two errors, one in labview and one in keithley.

 

The error in labview was "Error -1073807339 occurred at visa read in keithley 2182a.lvlib:Initialize.vi -> Keithley 2182 Relative Measurement.vi"

 

The error in Keithley was "Error +803 RS-232 Break detected".

 

Would anyone know the reason for these errors?

0 Kudos
Message 3 of 3
(1,379 Views)