Showing results for 
Search instead for 
Did you mean: 

Instruction could not be read.

I am at a loss here, I can not launch LabVIEW any more. I keep getting this error message.

LabVIEW:LabVIEW.exe - Application Error
The instruction at "0x005055a7" referenced memory at "0x09d61000". The memory could not be "read".

This problem did not start happening until I took out a MXI-3 controller, I didn't pull it out hot. I spent the day Friday uninstalling LabVIEW first, didn't fix it. Then I unistalled all of NI software on my machine. Didn't fix it. I spent Monday having my IT department wipe my machine clean and reimage it. That didn't fix it. I even replaced the memory in my machine. That still hasn't fixed it. I don't get any other errors running a different app, like Lotus notes or Microsoft office.

Has anyone seen this before and help me out?
Thanks in advance,

System specs:
P4 2.8GHz
512M mem
clean load of Windows 2000 SP4
Only other software loaded currently is MS office 2000 and Lotus Notes.
0 Kudos
Message 1 of 7
Is it a situation similar to this link?

I don't think the problem is related to your PC or OS.
Running Win-2K on a good machine.. 🙂

What version of LV are you using?

Message 2 of 7
No, I would get past the splash screen and that is when it would crash. I could not continue loading LabVIEW. It would just give me the option to exit.

I took all of my VI's out of the user.lib folder and LabVIEW runs fine. I have copied my VI's back one at a time testing to see if LabVIEW would crash and I can not get the crash to happen again. I am not sure what was happening. I thought that I might of had a corrupt VI, but I have been able to open a majority of them and use LabVIEW. This might sound like a dumb question, but is there a limit on the number of VI's you can put in the user.lib folder?

I am running LV 7.1. I have not installed any other components yet.
0 Kudos
Message 3 of 7
Hi Ben,

So now that you have copied all of your VIs out of the user.lib folder, everything is working fine? How many VIs did you have in there? Have you been able to put them all back in and LabVIEW is no longer crashing?

There is an article about this error here:
but it is not the same issue you saw, but I wanted to show it to you in case you had been running something like this.

0 Kudos
Message 4 of 7
I copied all of my VI's out of the user.lib and everything worked fine. I then started to copy back my most recent VI's to see if they were the ones causing the problems. They all worked fine. I then started to copy blocks of 5 to 10 vi's at a time, there are a lot of them. With each block that I moved I would launch LabVIEW to see if the problem was still there. I could not get LabVIEW to crash again after I moved all the VI's back into the user.lib folder. I am not sure why. There are several different projects over the years and some of them have used CIN. The drivers for the Tektronix TDS 7404 is built around one DLL and they use CIN's for everything. I have not done anything requiring a call to a DLL so the drivers from Tektronix are the only ones that I know of. That hasn't crashed either.

As for the number of VI's I have no idea. There is over four years of work there, when I use the Find VI's tool it reports back 8960 VI's in the user.lib folder. Is this the wrong place to store code?
0 Kudos
Message 5 of 7
Hi Ben,

Usually, the user.lib folder is used to store subVIs that you use often so that you can easily access them from the functions palette. However, there should not theoretically be any limit of the number of VIs you can put in that folder. The effect you might notice from having so many VIs in this folder is that LabVIEW or your functions palette may load slower than normal.
0 Kudos
Message 6 of 7
Hi Laura,
It does load slower. I will move the VI's that are not used all that often. I will keep the VI's that I use frequently in the user.lib folder. As far as the crashing problem it seems to have resolved its issue. I am back up and running now. Thanks for your help.
0 Kudos
Message 7 of 7