LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Installing the 8.2.1 run time engine on a system with LabVIEW 8.2 installed

Note: This is a cross-post to LAVA.

If I have a system with LabVIEW 8.2 installed and I upgrade only the RTE to 8.2.1 (leaving LabVIEW 8.2 installed) will I run into any problems?
  • Will applications that I build in LabVIEW 8.2 still run correctly?
  • Which RTE will applications that I build in 8.2 require? (I'm presuming that the 8.2.1 RTE upgrade will not touch the lvapp.lib stub used by the app builder and that apps built in 8.2 will run in the 8.2 RTE)
Here is what I (think I) know:
  • The 8.2.1 run time engine (RTE) is an upgrade to the 8.2 RTE, meaning that the 8.2 and 8.2.1 RTEs cannot be installed at the same time.
  • Applications built using LabVIEW 8.2 will run in the 8.2.1 RTE, however apps built using LabVIEW 8.2.1 require the 8.2.1 RTE and will not run in the 8.2 RTE
Has anyone attempted this?

Thanks,
0 Kudos
Message 1 of 20
(3,946 Views)
Hi Jim,
Anything that we product that is X.X.X is mostly a bug fix release, and so you are correct in that it installs over X.X (your example 8.2.1 installs over 8.2 and so it is not possible to have them installed at the same time separately). It also means that there is a good chance that you can interchange VIs and projects without a problem, but it is not guaranteed.
 
This means that applications built in LV 8.2 can run using 8.2.1 RTE, and LV 8.2.1 applications can probably run with 8.2 RTE, but it is highly recommended to have the same version of RTE as LV.
 
Is there a specific reason you only upgraded the RTE and not LV? If not, I would suggest going ahead and upgrading to be sure.
 
Stephanie
0 Kudos
Message 2 of 20
(3,903 Views)
Hi Stephanie,

Our company makes a software application (VI Package Manager) that is built as an EXE.  Our users generally have one or more LabVEW development environments installed on thier system.  We are currently testing VIPM as an EXE built in 8.2.1, which requires that our users have the 8.2.1 run time engine installed.  However, our users might not want to upgrade thier 8.2 development environment to 8.2.1.  This is why the development environment and the run time engine should be decoupled from each other -- are they?

Thanks,

-Jim
0 Kudos
Message 3 of 20
(3,899 Views)
Not only might not want, but might not be able to. Getting Version 8.2.1 requires that you be on the SSP (according to this page), even though it's supposed to be "just" bug fixes only). Our SSP expired, and not likely to be renewed, so we're stuck at 8.2.
0 Kudos
Message 4 of 20
(3,892 Views)
smercurio_fc: I believe that it is just a myth that you need the SSP to get the 8.2.1 development system upgrade -- You can download the LabVIEW 8.2.1 evaluation version and it should activate with your 8.2 serial number.  However, the 8.2.1 development system upgrade has nothing to do with my original question -- I am asking about whether I can install the 8.2.1 run time engine on a system with 8.2 development environment without issue.  Thanks!
0 Kudos
Message 5 of 20
(3,888 Views)
Errr.. I was following up on your comment about users not wanting to upgrade their 8.2 development environment to 8.2.1 in order to use an update VI Package Manager...

My point was that if you were to recompile the VI Package Manager using 8.2.1 and that required me to update my development environment in order to use it, I would not be able to because as far as I knew you could only get 8.2.1 through the SSP. I hadn't considered the evaluation version route, and I'm not sure whether that would be OK with NI licensing. I'm not saying I would be required to update my development environment, and I can't see why I would need to as I should be able to install the run-time engine separately, but I understand your request for confirmation of this. It was not my intention to divert the discussion to an 8.2.1 upgrade issue.
0 Kudos
Message 6 of 20
(3,882 Views)
smercurio_fc: You're absolutely right.  In fact, there are many reasons users might not want to upgrade the development environment to 8.2.1 and that's exactly why the run time engine and the development environment must be decoupled.  Thanks for the support 🙂
0 Kudos
Message 7 of 20
(3,877 Views)

@smercurio_fc wrote:
Not only might not want, but might not be able to. Getting Version 8.2.1 requires that you be on the SSP (according to this page)

The page you quote only refers to the development environment. Since whenever I can remember, the LabVIEW run-time engine was always a free download (no purchase required). it still is. Let's not add confusion. The run-time and the development environment are decoupled as far as an installer and download. I guess the main issue Jim is raising is if having an 8.20 dev env. and 8.2.1 run-time will cause problems and if there is a reason the end user would want to avoid this problem. The 8.2.1 run-time overwrites the 8.20 run-time so you will no longer have the 8.20 run-time.


Michael Aivaliotis
VI Shots LLC
0 Kudos
Message 8 of 20
(3,850 Views)

@Michael Aivaliotis wrote:
Since whenever I can remember, the LabVIEW run-time engine was always a free download (no purchase required). it still is. Let's not add confusion. The run-time and the development environment are decoupled as far as an installer and download.


I'm well aware of this. I have been using LabVIEW since version 2. I wasn't trying to add confusion, nor trying to hijack this thread into a development environment update issue, but clearly my post was misconstrued and the exact opposite happened. I said it before and I'll say it again: I was following-up on Jim's comment about making sure that a user would not be forced to update their development environment due to some uknown coupling issue, and that (quote) "our users might not want to upgrade thier 8.2 development environment to 8.2.1". My point was that I agreed with this statement, and wanted to reinforce it by saying that some users can't update to 8.2.1 since the 8.2.1 development environment update requires SSP (at least according to the page I linked to). I wanted Jim to keep this in mind when deciding what to do. I also said that I didn't believe there was a coupling issue, but I don't work for NI, so I don't know what goes through their respective mind. For example, if I have to update my LabVIEW 8.2.1 run-time in order to use the VI Package Manager, and I develop my software with 8.2, what happens, if anything, when I build an application and I try to distribute it on other computers? The other computers won't have 8.2.1. They will be at 8.2. The seemingly obvious answer would be: update the run-time engine on the other computers. But is this all?

That's it. That's all that I was saying. Next time I'll be a little more clear, or perhaps I'll just stay out of the conversation alltogether. Smiley Wink
0 Kudos
Message 9 of 20
(3,836 Views)

Jim:

I think you are just going to have to try it... perhaps using VMware?.... May try  it myself, I am upgrading Dev Suite and have some free time... I'll let you know my findings.

 

smercurio_fc:

Please don't stay out of the conversation. If being misconstrued is enough to leave, then most of us should be long gone! I don't know about everyone else, but I appreciate ALL comments... being miscontrued typically means your thinking outside the rhelm of general thought, and there is no greater contribution.

0 Kudos
Message 10 of 20
(3,823 Views)