LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Installer wants older Runtime

Hello again

 

I'm trying to update an installer, so all the settings are the same as they were before, i just replaced some files in the project.

Under Additional installers i have selected

NI Labview Runtime 2019 f2

NI-DAQmx Runtime 19.6

NI-VISA Runtime 18.5

NI PXI Platform Services Runtime 19.5 (greyed out)

AeroSoul_0-1720597590082.png

AeroSoul_1-1720597598428.png

 

Whenever i click OK though, it wants LabVIEW Runtime 2018 SP 1 f4. When i made the installer initially this was not required and i don't think any files use 2018 version, since i use LV 2019.

AeroSoul_2-1720597628742.png

 

Any idea why this would be required and how i could get rid of this requirement?

 

Another thing that bugs me is, this appears every time i click OK, so the only option to go back to editing the installer project is to click cancel... which undoes any work i did on the installer.

 

0 Kudos
Message 1 of 3
(110 Views)

Some components in DAQmx or NI VISA might require that LabVIEW runtime. NI-Max test-panels and similar used to have LabVIEW runtime dependencies in the past.

Rolf Kalbermatter
My Blog
0 Kudos
Message 2 of 3
(93 Views)

@AeroSoul wrote:

 

 

Another thing that bugs me is, this appears every time i click OK, so the only option to go back to editing the installer project is to click cancel... which undoes any work i did on the installer.

 


nasty

 

 

we used the application builder  to create offline installers (one .zip containing everything, the NI term is package installer) via a dummy installer .lvproj,

but we had similiar Issues when building the 2024 installers, that is why we have been moving on to the NI package builder

 

at the moment, the ni package builder works better for us.

 

0 Kudos
Message 3 of 3
(48 Views)