From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.


Showing results for 
Search instead for 
Did you mean: 

How to remove something that's not there?

Evening everyone,
I have a rather interesting situation on my computer. I recently downloaded the latest NI-DAQmx drivers from here, and attempted to install them.
I received this error message:

The only version of NI-DAQ, to my knowledge, that I've ever installed is Traditional (legacy) NI-DAQ.
So, I did as it said and went to Add Remove Programs to remove NI-DAQ. As you can see from the National Instruments Software application, there is no NI-DAQ listed:


Checking the installation directory I see no NI-DAQ folder:

but in MAX I do get Traditional NI-DAQ listed under the software tab:

But you can't uninstall things from MAX.

So... how do I remove Traditional NI-DAQ from my machine when I can't find it on there anywhere???

(Sorry about the huge pictures, but thought they clearly explained my plight Smiley Tongue )


0 Kudos
Message 1 of 11
There is a utility that is going around from NI that does a great job of removing their products. The utility is called msiBlast. Try using this utility and see if it removes the software for you.
I am attaching it to this post. It is an executeable, if you do not trust EXE from individuals then you can do a search on the NI site for it. You will have to change the file extension to .exe instead of .jpg before you open it. The reason for the change in the name is because you cannot include exe files as attachments to the forum

Message 2 of 11
THanks for this. I did do a search for MsiBlast, as you suggested. From what I can tell, it erases all traces of anything National Instruments based. Is that true???
I'd rather not be losing my entire series of installations if I can prevent that, just Traditional NIDAQ.
I dare not run the program in case I get no options menu to select specifics, will it just immediately start eradicating everything NI from my machine?
0 Kudos
Message 3 of 11
OK, took the plunge and ran MsiBlast.exe. Thankfully is does present a list, and oh man what a long list it was too!
I found one item only in the list that had DAQ in it's title, so I uninstalled it (it was called DAQ for MAX, or something similar).
It's the only DAQ installation I can see in the MsiBlast list yet the DAQmx installation still fails with the same error as shown by my first image in my opening message.
I've included the list from MsiBlast below, maybe someone can see something I need to remove? I certainly can't see anything else DAQ related in there. Any help would be most appreciated as I really need to get this DAQmx installed! Smiley Sad

0 Kudos
Message 4 of 11
Uninstall measurement and automation explorer. Then when you install daqmx this automatically be reinstalled.

Message 5 of 11
OK, I removed MAX (which required the removal of many other reliant packages) and retried the NIDAQmx installation. Same error - "Please remove NI-DAQ 6.8.x from your system"
Now what?? Smiley Surprised
0 Kudos
Message 6 of 11

Except for digging into the registry and deleting the key I have no Idea. Hopefully someone from NI will chime in.



Message 7 of 11
This is driving me mad. So I've taken a risk and deleted a registry entry that refered to "NI-DAQ version 6.8.1". (Of course, I backed up first). Restarted the NI-DAQmx installer - IT WORKS! Smiley Very Happy
Thanks for all your help Joe! Smiley Happy

Message Edited by Riggy on 12-04-2007 01:55 PM
Message 8 of 11
Thanks for the stars. Glad I could help.

Message 9 of 11
I have the same problem and I will now go and look for the registry key... Hope it helps!!
0 Kudos
Message 10 of 11