LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to install unsupported (obsolete) toolkits/modules in newer LV versions?

Hello,

 

Installers of LV toolkits/modules do not permit installation in newer LV environments. I don't know if that is necessary, but I am quite positive most of them would actually work 100%. If this "feature" cannot be revised, is it possible to obtain a workarround procedure (file/folder specification) for manual installation?

 

I am specifically interested in installing the LV 2012 ARM Module in LV 2014. Even if I find time and mashine to install LV2012, than the ARM module, I am not sure I would be able to completely "move/copy" the ARM installation into the corresponding folder structure of the LV 2014.

 

So, is there an explicit  manual installation procedure?

 

Thanks in advance,

0 Kudos
Message 1 of 5
(2,079 Views)
I have no knowledge of the specific toolbox you are asking about, but the ability to move old toolboxes to new LabVIEW depends (for the most part) on things like hardware or DLL compatibilities.

If a toolbox is written in 100% LabVIEW, you should be able to use it with no problem. Earlier this year I needed to access a device via telnet. Unfortunately, NI had dropped the telnet VIs from the internet toolkit is 2012. I was able to copy the old telnet VIs to my 2014 installation, and they worked fine.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 2 of 5
(2,057 Views)

Considering that that toolkit is a compiler, I do not think you are going to get it to work.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 3 of 5
(2,006 Views)

Hello Crossrutz,

 

Thanks for responding. I agree it is a (pre)compiler but the true ARM compilation is done by the uKeil external compiler...

Are you positive it will not work in LV2014?

0 Kudos
Message 4 of 5
(1,989 Views)
No, we aren't sure -- which is sort of the point. It all depends on how it was written and if there are any dependences.

You need to try it.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 5 of 5
(1,972 Views)