LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

HUGE bug on "Get section names" (Configuration file vi)

LV 2015SP1

 

The vi "Get section names" is bugged.

Severely.

 

If you input a regular INI file, it returns a WRONG section names array.

The first section is SKIPPED (which is wrong)

If you have a INI with just one section, it return empty array (which is wrong)

 

Guess what? ZERO DOCUMENTATION ON THIS BEHAVIOUR.

ZERO

ABSOLUTELY NOT WRITTEN ANYWHERE.

 

I want now the name of the person that coded that.

He must be FIRED.

 

The VI is simply WRONG.

 

It turns out this retarded software developer decided that "the first section is comment", but it's not

 

THIS IS THE MOST STUPID IMPLEMENTATION I'VE EVER SEEN

 

THIS MUST END MAN!

 

I WANT HIS NAME.

I WILL COME TO YOUR HOUSE MAN, YOU MADE ME LOSE PRECIOUS TIME BECAUSE YOU CANNOT CODE.

IF YOU CAN'T CODE, JUST GTFO HERE, CHANGE PROFESSION, CLEAN THE STREETS OR LIVE WITH FOOD STAMPS, UNDERSTAND?

I KNOW YOU READ ME, I HAVE 0 RESPECT FOR THOSE LIKE YOU.

0 Kudos
Message 1 of 31
(3,973 Views)

@Ironman_ wrote:

 

 

Guess what? ZERO DOCUMENTATION ON THIS BEHAVIOUR.

ZERO

ABSOLUTELY NOT WRITTEN ANYWHERE. 

 


Here's the documentation for the VI in LabVIEW 2015. You mentioned using LabVIEW 2015 SP1, which hasn't shipped yet, so I can't speak to its documentation, although I assume it is the same as the screenshots below:

 

1.png

 

Clicking the link gives you:

 

2.png

 

You mentioned using a "regular INI file". If "regular" in your case means an INI file with some or all of its contents not under a named section, I would not expect it to behave the way you desire, per the documentation.

Message 2 of 31
(3,943 Views)

@Ironman_ wrote:

If you input a regular INI file, it returns a WRONG section names array.

The first section is SKIPPED (which is wrong)

If you have a INI with just one section, it return empty array (which is wrong)


Could you post an example of your configuration file?  I have never seen this happen the way you are describing.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 3 of 31
(3,924 Views)
Can you post your INI file?

It sounds like your INI file is just a list of key/value pairs and doesn't actually contain any 'sections' (a header enclosed in square brackets) so I would have expected the 'list sections' to be empty.

I think you can use the 'list keys' function to return the keys that are present in the file.

Whilst I can appreciate that sometimes these things can be frustrating (but a necessary evil when writing software!) - I don't think calling NI staff a 'retarded software developer' and other insults on their own forums is really very appropriate. I'm sure you have never made a mistake when programming...(and it doesn't even look like this is a bug!)

LabVIEW Champion, CLA, CLED, CTD
(blog)
0 Kudos
Message 4 of 31
(3,913 Views)

I've yet to see a bug, just a lot of yelling.  If you ever want this issue fixed (if there is an issue) then post a detailed example on how to reproduce the issue.  I mean I can tell Ford they make a crappy car, but unless I bring evidence to the crappiness I doubt they will do anything.

 

Also you said you were using LabVIEW 2015 SP1 but I don't think that is released yet.  Please provide a link to where you got 2015 SP1 from.

0 Kudos
Message 5 of 31
(3,890 Views)

Quoting Jim Croche

 

"

You don't tug on Superman's cape,

You don't spit n the wind,

You pull the mask off the old Lone Ranger and you Don't mess around with Jim!

"

 

Add me to the list that want to see the ini file that demonstrates that problem.

 

While I have many time locked horns with Superman, I am trusting in him until I see evidence of kryptonite.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 6 of 31
(3,868 Views)

@Ben wrote:

While I have many time locked horns with Superman, I am trusting in him until I see evidence of kryptonite.


The OP in not in the DC universe, but the Marvel universe (Ironman).  So maybe your analogy doesn't work.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
Message 7 of 31
(3,855 Views)

Is it just me or do the words HUGE, STUPID and FIRED remind anyone of certain rhetoric in the current presidential race? 😄

Message 8 of 31
(3,815 Views)

 

Spoiler

"

I'll make NI great again!

 

I will build a great re-use Library and make Mexico pay for it.

 

"

 

 

 

Nah it is just you Christian.

 

Smiley Tongue

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
Message 9 of 31
(3,789 Views)

Can you read your file raw content using labview 'read text file' and not notepad or some sort of generic text software.

 

I have already had a similar issue where there was a weird hidden character at the beginning of my file (not even shown by notepad++), before the first bracket so labview could not detect the first bracket at the beginning of a line. and everthing was messed up like you describe.

 

Before calling NI to fire some great dude I tried to see what was wrong.

0 Kudos
Message 10 of 31
(3,771 Views)