Showing results for 
Search instead for 
Did you mean: 

File drag and drop with Labview 7 and Mac OS X Tiger?

Hi folks,
I've lost the ability to drag and drop files into front panel file path controls, since I upgraded to a new OS X version. Specifically:
What used to work:
    - Labview 7.0
    - Mac OS X 10.3.x
    - drag file icon from desktop and drop onto file path control (file path control shows path to dropped file)
New action taken:
    - lost old Mac (Titanium) with OS X 10.3.x
    - bought new Mac (Aluminum) with OS X 10.4
    - installed OS X 10.4 "over" 10.3 disk (did not build from scratch)
What happens now (three days after birth of new system):
    - all my past Labview apps still seem to run
    - but, if I drag a file from the desktop and drop it onto the file path control I see:
          - file path control "outlines" indicating that it understands the intended drag and drop action
          - when the file is dropped the file path control does not report the new value
          - And the file path control still has it's old value

Anyone else seeing this? Am I missing something obvious (Labview or OS X preferences)?

Thanks in advance,
0 Kudos
Message 1 of 13
Did you install the OSX upgrade before or after you installed the Labview 7 Runtime Framework?  Before would be best.  I had a strange Photoshop problem where it wouldn't open files when I double-clicked them, and it was because a file did not get copied across to the new System Library when I upgraded from 10.3 to 10.4
0 Kudos
Message 2 of 13
Thanks for the info,
Initially, I installed 10.4 over 10.3, with LV 7.0 already installed (so, after).
So, I reinstalled LV 7.0 on the 10.4 system. I then got 10.4.6 as an upgrade online (automatic upgrade).

Is drag and drop working for you? If so, what version LV and OS X?
0 Kudos
Message 3 of 13
Ooops, I got the order wrong there... corrections:
- initially installed 10.4.2 over 10.3.6, with LV 7.0 already installed (had not discovered problem yet)
- installed 10.4.6 via automatic upgrade online
- soon discovered drag and drop problem
- reinstalled LV 7 on 10.4.6 system
- still have drag and drop problem

I guess I could try to install OS X 10.4.2 on a clean disk, then install LV 7 and see if the drag and drop problem persists. But, of course it's easier to first see if someone else has already gone done this road already...

Of course it's trivial to check for this problem:
 - new VI
 - place filepath control on front panel
 - drag and drop any file (or folder) icon onto the filepath control (VI does not have to be running)
 - the filepath control should report the path to the dropped file/folder
0 Kudos
Message 4 of 13
I did not know that would work before, so I had never tried it. It fails as you describe on LV 7.1 and OS X 10.4.6, but works fine on LV 8.0.

0 Kudos
Message 5 of 13
Thanks Lynn,

Yes, it's worked since atleast LV 6 (with OS 9).
It works with LV 7.0 on OS X 10.3.x.
It works on PCs (LV 6 and LV 7).

It's a really nice feature, I find.

I can't migrate all of my apps to LV 8 yet... too many apps to regression check, and too many customers with LV 7.

Hmmmm.... how to figure out if it's a LV issue, or an OS X issue?????
0 Kudos
Message 6 of 13
Hello all,
This is a known issue and is rooted in a system API change which Apple made between OS X versions 10.3 and 10.4.  A bug was filed to Apple regarding this issue, but as empirically discovered in this stream, we fixed it on the LabVIEW side for version 8.0.
Apologies for any inconvenience!
Best Regards,
0 Kudos
Message 7 of 13
Thanks for the info. Do you have a sense of how seriously Apple sees the problem? Can we find out the Apple Bug Report#, and when the report was presented to Apple? I'd like to:
1) track Apple's progress in resolving the issue
2) (try to) determine how serious Apple is in resolving the issue
0 Kudos
Message 8 of 13
I don't know how seriously Apple sees the problem, but it doesn't seem plausible that they would rev the OS on account of just this problem with LabVIEW, particularly since we worked around it for the latest version of LabVIEW.  I understand you are working with another engineer at NI via direct email regarding this issue, and that is going to be a better forum for discussing the possibility of obtaining the Apple bug report number.  In the event R&D is willing to reveal it, I presume they will be more comfortable doing so on a case by case basis, as opposed to posting it on the external discussion forum.
Thank you, and sorry for the inconvenience you have encountered due to this issue.
Best Regards,
0 Kudos
Message 9 of 13
Thanks JLS,

Yes, I got the Apple Bug Report # and requested status from Apple.

Apple is still investigating the issue.... that's about all they would commit to.

I'm assuming that NI is not able to/interested in propagating the LV 8 fix to LV 7... do you know if it's been considered?

BTW, thanks for being so diligent in scanning these forums, and supplying feedback... I am constantly impressed with NI's view on customer support (I should add that Apple also responded in very short order to my request for info).
0 Kudos
Message 10 of 13