LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error19: Problem to make a contact to LabView

Hallo,
I'm an absolute LabView beginner and have a problem to start the measurement. I try to read out 9 temperatures.
With the DECON Utility I have searched for the modules. DECON finds them and I can see the temperature values. But when I try to start my measurement with LabView it comes Error19.
With the Program Measurement&Automation I see a ComPort, but it has a red cross and I can't get any Informations about it.
So I had the idea, that it isn't a problem with the Vi,but a problem with the work together from computer and LabView, or?

 

My Hardware is: I-7563
I-7018Z
At the same time I want to read out some Digital Input therefore I have a I-7041D (it doesn't work too)
In future I want to make an analog output and therefore I have a I-7024

 

Software:
LabView 2011
Windows XP
and any drivers and other things a could find for LabView. I think a list is under "max_report"

 

I try to read the temperatures with the Vi for a 7018 where I change the address, the comport and the baudrate like DECON Utility told me.

I hope you can help me, I try it for the last 4 weeks and have absolute no idea. Please tell me everything simple as possible.

 

Thank you,

Chrissi

Download All
0 Kudos
Message 1 of 3
(2,157 Views)

The 1st problem is to get the serial port working. You do not say what type of hardware you are using for the serial port. If it is a USB to RS232 device they can be difficult to get working, for a number of reasons. Check to see if the serial port is shown as working correctly in Windows Device Manager (XP, Vista, 7). Until it is working in Windows your chances of getting it working in MAX and LabVIEW are very low. 

 

Once the serial port is working in Windows and MAX try communicating with the device using the the VISA Test Panel in MAX. The test panel lets you send string commands to the device and receive data back. You will need to know what commands the device accepts. The screen shot shows you where to find the Test Panel:

 

Measurement&Automation.jpg

 

Once you can communicate with the device from the VISA Test Panel in MAX, your LabVIEW software should be able to communicate with the device.

 

 

David C
0 Kudos
Message 2 of 3
(2,140 Views)

Hallo,

thank you for your fast reply.

My Hardware is a I-7563 ( RS-485) or a I-7561 ( RS-232/422/485) I checked it with both, but it doesn't work.

The device manager says everything ok. I made a lot of screenshots, so you can see.

Using the Measurement&Automation the red crosses are away but it still doesn't work.

I open the VISA Test Panel.

In the category "I/O" i didn't know which I have to select under "Select or enter command" so I test everything. The results were the same. As you can see in the pictures.

Write: no error

read: error

LabView still doesn't work.

I hope I could answer everything and you can help me.

Chrissi

0 Kudos
Message 3 of 3
(2,111 Views)