Showing results for 
Search instead for 
Did you mean: 

Error while building a .EXE "Exception : Unknown (0x00000000) à EIP=0x005E488E"



I am using Labview 2023 Q3 with Community access, and I try to build my .EXE but I have this error which appears and I can't do anything.



LabVIEW closes and if I try again it happens again. I have never faced this error before. I don't even know which VI uses this "".


I have tried to launch LabVIEW as an administrator but it didn't work. (Because sometimes it is written violation access).

Can anyone help me please ?

0 Kudos
Message 1 of 6

The path to "" shows that it's just a part of the Application Builder VIs (the "AB" in the path).  So it's not called by any code you wrote.


Best guess is that this VI is very minimal, based on its size, and based on its name it probably just opens another VI by reference, probably opening all the VIs that need to go in your application one at a time.


As such, best guess is that one of the VIs that you are trying to build into the application is corrupted.


Try going to this folder:

C:\Users\<your user name here>\Documents\LabVIEW Data\LVInternalReports\LabVIEW\


There should be a folder under that matching the edition of LabVIEW you use.  I don't know what Community edition would put there.  Open that, then inside that find the folder there that matches one of the crashes.  You can match the date\time or the report ID.   Inside that you'll find a ZIP file, and inside that there is usually a few unhelpful DMP files but in some (not all) cases there will be a "lvlog.txt" file that contains some information about what was happening when everything crashed.  Looking through that file can sometimes point towards a corrupt file.

Message 2 of 6

So I didn't have a really good txt file, so I ran again to build and then I got something better.

I attached the file, nothing is linked to my code I think, only LabVIEW VIs. What do I do ?

Also, I am using sound library to read .wav files, and it seems that it is crashing when it is the lvsound2.llb compiling.

0 Kudos
Message 3 of 6

Update : I have created a blank project with a blank Main VI. I have tried to compile and the same error happens.


Can I create .EXE with Community Edition ? Is it access problem inside my laptop ?

0 Kudos
Message 4 of 6

Community edition can definitely make EXE files.


I have seen a few other reports of bugs with the latest 2023 Q3 edition of regular LabVIEW.  Maybe you could try an earlier version (2023 Q1 or 2022 Q3) and see if it works?  The list of new features from 2022 to 2023 is pretty small, you likely won't miss anything.  Most of us on the forum here actually use older versions just to avoid having to resave all our existing files under new formats yearly.

0 Kudos
Message 5 of 6

I have downloaded LabVIEW 2012 SP1 (because I used it at work before) and it works !


However, I think I can use Community Edition with other version than the latest. So I have only 45 days before expiring.


Thank you for your help, and if you have any idea about LabVIEW 2023 Q3 to make it works, I am here. I will try to uninstall and install again 2023 Q3 to see if it changes something.

0 Kudos
Message 6 of 6