Showing results for 
Search instead for 
Did you mean: 

Error 7 occurred at Open File,NI-488: Nonexistent GPIB interface

I did some clean-up of my computer and have been having issues ever since.

I'm not the one that did the programming; the person who did is long gone.

The VI loads fine but when I hit run I get:


Error 7 occurred at Open File


LabVIEW:  File not found. The file might have been moved or deleted, or the file path might be incorrectly formatted for the operating system. For example, use \ as path separators on Windows, : on Mac OS, and / on Linux. Verify that the path is correct using the command prompt or file explorer.
NI-488:  Nonexistent GPIB interface.


All the necessary VIs are available and I've tried changing all the file calls in the VIs to the new locations but the error is the same.


Any suggestions?



0 Kudos
Message 1 of 6

So it seems it was an issue linking files. I really wish the error code could have told me more about where the problem was.

Oh, well, at least it works now.

0 Kudos
Message 2 of 6

By "linking files" you mean what?  Be more specific (file path?) and mark your post as a solution.

Reese, (former CLAD, future CLD)

Some people call me the Space Cowboy!
Some call me the gangster of love.
Some people call me MoReese!
...I'm right here baby, right here, right here, right here at home
0 Kudos
Message 3 of 6



I'm having the same problem. What exactly did you do to fix it? I don't know what you meant by "Linking Files".


Thanks in advance,



0 Kudos
Message 4 of 6

Error 7 is a generic file not found.  If it is happening after cleaning up files, more than likely you moved some subVIs called in a main VI to a new location on your computer.  If all the VIs are in a project, a possible solution would be to remove the vis in the project directory and add them back to the project as they may be pointing to a previous location where the files were once stored.  Perhaps this is what Anon123123123 meant by "linking".  Hope this helps.





Isaac S.

Isaac S.
Applications Engineer
National Instruments
0 Kudos
Message 5 of 6

Oh OK. I understand what he meant now. It appears that I did have some files that moved after creating the excecutable. Now I have the user select the location of the file, and it's working perfectly.


Thanks for the help.



0 Kudos
Message 6 of 6