Showing results for 
Search instead for 
Did you mean: 

Error -2147319779 Library not registered when trying to use ActiveX to open microsoft word


I am having problems when I try to run an executable on a PC.  My Development PC that has Labview 8.2 and Microsoft Word 2000.  I am able to run my vi (see pic attachement) without any problems.  I compile it as an executable and run it on my Development PC and everything still works ok.  I deployed it on another machine with Labview Run-Time Engine Version 8.2 and it works ok.  I tried it again on a third PC and get the following error

Error -2147319779 Library not registered

All PC's are running windows XP and all have microsoft word 2000 installed.

I have tried uninstalling National instruments software (Run-time Engine) as well as Microsoft Word on the failing PC, but still no luck.

Does anyone have any suggestions.

0 Kudos
Message 1 of 2
Hey Steve,

I hate to throw links at you, but it appears this problem has occurred with developers before.
Easy text Report.VI...not so easy (You have to love a title like that)
Problem with LabVIEW Run Time communicating with Access Database

These links may not seem relevant to your issue, but at its base the Report Generation and Database Connectivity toolsets are simply ActiveX/.NET calls into Microsoft products (or ODBC, etc.). This is similar to what you're doing.

Also, I would try reinstalling MS Office. This has been known to solve the problem.


| Michael K | Project Manager | LabVIEW R&D | National Instruments |

0 Kudos
Message 2 of 2