LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -2147217843

Hello
I am getting the error msg :
"Error -2147217843 occurred at DB Tools Open Connec (String).vi->DB Tools Open Connec (Path).vi->DB_1.vi
Possible reason(s):
Exception occured in Microsoft OLE DB Provider for ODBC Drivers: [Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve the connect identifier specified
 in DB Tools Open Connec (String).vi->DB Tools Open Connec (Path).vi->DB_1.vi"
while tring to connect to oracle DB.
What can this wrror mean i am using a UDL file which has no problem.
 
anyone?
0 Kudos
Message 1 of 4
(5,697 Views)
Well, maybe. Either the UDL is pointing to the wrong entry in the TNSNAMES file, or the TNSNAMES file doesn't contain the entry that you think it does. In either case this is an Oracle issue that your in-house folks responsible for the Oracle database should be able to assist you on. If you don't know what a TNSNAMES file is, call your Oracle support folks now. If you do know what I mean when I refer to a "TNSNAMES file", here's a place to start the troubleshooting:
  1. Open the UDL itself by double clicking it. It should open to the Connection tab.
  2. Click on the Provider tab and make sure that Oracle Provider for OLE DB is selected.
  3. Return to the Connection tab and make sure the value in the Data Source field is the name of a valid TNSNAMES file entry.
  4. Make sure your user name is in the User name field
  5. If it's blank, enter your password into the Password field
  6. Click the Test Connection button
  7. If this fails (and from what you said it should) call your Oracle support folks - until this works LV's connection won't work.
  8. If this works, make sure that LV is pointing to the correct UDL
  9. If testing the UDL works (step 6), and LV is pointed to the right UDL and it STILL doesn't work, let me know and I'll post some simplifed test code.
Hope this helps. Let us know how this comes out.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
Message 2 of 4
(5,689 Views)

I got this error with SQL Server (in TestStand) because I forgot to check "Allow saving password" on the Connection tab of the UDL file editor (Data Link Properties dialog).

 

-Jason

Message Edited by LabBEAN on 03-27-2009 11:24 AM

Certified LabVIEW Architect
TestScript: Free Python/LabVIEW Connector

One global to rule them all,
One double-click to find them,
One interface to bring them all
and in the panel bind them.
0 Kudos
Message 3 of 4
(5,163 Views)

Hello Mike,

I have the same issue, for me, testing the UDL works (step 6), and LV is pointed to the right UDL and it STILL doesn't work.

Does it related to bit ness of LabVIEW and Oracle client.
I have installed Oracle 64 bit and LabVIEW installed is 32 bit.

 

Thanks in advance

Rahul

LV Error.png

UDL_Connection.png

  

0 Kudos
Message 4 of 4
(911 Views)