LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1003 in Actor.vi inside EXE

I'm developing a project that uses the Actor Framework. I have already made it to build an EXE for it, but I've been working for the last month without building new executables.

 

Recently, after building a new version of the executable and trying to run it, I'm receiving the error 1003 (VI not executable) from the Actor.vi in before calling it asynchronously in the Launch Root Actor mehod. I tried to build it with debugging enabled and with "Wait for debugger on lauch" set to true. As I tried to debug the Actor.vi, I noticed that several overrides of the Actor Core.vi (in case, the actors I developed) were broken.

 

In their block diagrams, I could see that these broken Actor Cores couldn't find some Send <Message>.vi. I tried several ways of forcing the App Builder to include these VIs, such as

  • Inserting the message classes in the "Always included" list of source files;
  • Explicitly defining the destination of the respective message classes and VIs;
  • Disabling the options to remove unused members of project libraries.

None of these helped. I have even tried to look up the contents of the <ExecName>.exe folder that the AppBuilder creates before zipping it and packing to the .exe file, and these message classes were actually there!

I also found this strange since the Application Builder should include these classes implicitly, once they're called statically in my block diagrams.

 

Any clue on what can cause this problem?

 

Thanks!

0 Kudos
Message 1 of 2
(1,822 Views)

Hello!

 

Check out ths old forum post:

 

Solved: Launch Actor- Error 1003 with no broken VI's
https://forums.ni.com/t5/Actor-Framework-Discussions/Launch-Actor-Error-1003-with-no-broken-VI-s/m-p...

 

It looks like is the same problem you are facing. See if the solution can help you. 

 

Also, check this article:

 

Error 1003 Occurs When Trying to Create an Executable
https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P9fiSAC

 

Hope it helps! Let us know about your steps. 

Bye! 

Isabelle Orlandi
Engenharia de Aplicações
National Instruments Brasil
0 Kudos
Message 2 of 2
(1,774 Views)