LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

EXE does not load *.lvlib

I have a project which uses *.lvlib. However, after creating an EXE, the program is not executable. The application starts with a "Broken Arrow". When I build the application in debug mode, I see that all VI's which come from the *.lvlib were not loaded (*.vi was not found). However, I have declared the *.lvlib as "always include" in the application. What bothers me most about this, 3 days ago everything worked and the changes since then are minimal. Even when I do an SVN revert to a version that was working at the time, the build is no longer possible. How can I force LabVIEW to include the *.lvlib correctly in the EXE?

Download All
0 Kudos
Message 1 of 7
(1,301 Views)

Look at the project in Files view.  Does the *.lvlib appear in the proper directory?  There may be a difference in where the file is actually located and where the compiler thinks it is located.  Just a thought. 

aputman
------------------
Heads up! NI has moved LabVIEW to a mandatory SaaS subscription policy, along with a big price increase. Make your voice heard.
0 Kudos
Message 2 of 7
(1,269 Views)

Hi aputman

 

Thank you for your reply. Yes the *.lvlib appears in the proper directory...

0 Kudos
Message 3 of 7
(1,226 Views)

You shouldn't have to "Always Include" the library since the files are statically referenced in the code.  As long as the *.lvlib is listed properly in the dependencies of the project, it "should" just work. 

You say changes were minimal but can you be more specific?  Most likely, this is an issue with dependency locations or the build settings.  Were any of those settings changed?

Have you viewed the project file in a text editor and looked for any anomalies in dependency paths (i.e. something like this ../../../../../../../ in the middle of a path)? 

Have you tried to restart LabVIEW or the PC since the issue started occurring?

Can you try to create a new build specification?  or even a new project?  (Make sure you have a good backup)

 

aputman
------------------
Heads up! NI has moved LabVIEW to a mandatory SaaS subscription policy, along with a big price increase. Make your voice heard.
0 Kudos
Message 4 of 7
(1,205 Views)

Thank you for your reply.

Ok i have deleteded the "always include" of the library.

Everything I checked was good.

The problem seems to be in LabVIEW Application builder itself.

The only solution it works is to build from down to the top MainVI (build a SubVI, build a SubVI how contains more, ..., and last but not least build the main).

I have no idea why it works, but now I can build the application.

0 Kudos
Message 5 of 7
(1,101 Views)

You didn't mention the LabVIEW version but....I have encountered problems like this when rebuilding a build specification especially on some LabVIEW versions. 

 

Try this:

  • From the project explorer select "Build Specifications"
  • Right-click and select "Clean all"

That will force the next build to recreate an entirely new source distribution rather than reuse some things that might already be found in the build output location. 

 

Also: watch out if you have multiple build specs.  A build all builds specifications as they are displayed from top down.  Often an exe is above a ppl forcing the exe to use the previous ppl before building the new one. 


"Should be" isn't "Is" -Jay
Message 6 of 7
(1,078 Views)

After a good month of developing i have the exact same behavoir again... For no reason.

Build a application, test it, do a small change - the application is broken after the build...

I need to say, that for some reasen, i don't like LabVIEW all the time...

0 Kudos
Message 7 of 7
(901 Views)