From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Dynamic Runtime Menus don't show underlined shortcut characters

The attached VI (edit of an NI example) inserts a File, Edit, Help menu with shorcut keys "_F, _E, _H".  The shortcut keys work, but, they do not show the underline on the letters until you use a shortcut key, and then they disappear after the menu closes.  That is different than how they behave if I used a static menu.  Is there something that can be done to get the underlines to always show?

0 Kudos
Message 1 of 8
(2,779 Views)

Sorry, it appears that there's a missing subvi link in that vi, however, you can delete the calls to that subvi without affecting the behavior of the vi.

0 Kudos
Message 2 of 8
(2,764 Views)

Here's the vi without the missing subvi

0 Kudos
Message 3 of 8
(2,763 Views)

Hi Thomas,

 

Thats the normal behavior of the shortcuts, usually if you open any program and press Alt that allowes you to see the underlined caracter of the shortcut. I already checked it with your VI and it works fine. If you want to check for that behavior, open Notepad and press Alt and it should work in the same way. Let me know if that is what you mean.

 

Regards.

Camilo Triana
Account Manager
National Instruments
camilo.triana@ni.com
0 Kudos
Message 4 of 8
(2,736 Views)

We appear to be seeing different behavior?

 see no underlined charectors before or after pressing Alt.  Only if I hit Alt+F do I see the File menu F underlined.  In notepad, nothing is underlined but if I hit "Alt" all of the shortcut charectors in all of the menus are underlined.  Meanwhile in a previous version of our software when we were using RTM files instead of dynamically generating menus, it always underlined the shortcut charectors for all menus regardless of whether Alt was pressed or a menu selected.

0 Kudos
Message 5 of 8
(2,728 Views)

I just tried your VI in LabVIEW 12, Windows 7, and the underlined characters show up when I hit the Alt key.

 

But you're right, the menu behaviour did change at some point. At some time in the past the underlined characters were visible all the time, but now the underlining only becomes visible when you hit the Alt key. I'm not sure if this was due to a change in LabVIEW, or a change in the operating system when we switched from Windows XP to Windows 7.

 

Edit: I just tried one of my old LabVIEW 8.2.1 programs in Windows 7, and the underlining is visible all the time, so there must have been a change in LabVIEW at some point.

0 Kudos
Message 6 of 8
(2,702 Views)

It's interesting that you and I are seeing different behavior.  I'll have some of my co-workers take a look and see if they also see differences between machines.

0 Kudos
Message 7 of 8
(2,672 Views)

Oh weird, I see what you're saying, it's not a computer difference.  However, LabVIEW is not behaving like notepad.  In LabVIEW if I hold down the Alt key nothing happens.  If I release the Alt key, then the underlines characters appear.   In Notepad if you hold the Alt key, all shortcuts are immediately underlined. So our difference in experience is probably a difference in habit.  I always hold the alt key when looking for a shortcut key in a menu.

 

I guess then, my wish for NI would be to always show the shortcut keys, or, at a minimum, always show them when the Alt key is depressed or the menu is activated.

0 Kudos
Message 8 of 8
(2,671 Views)