LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Does IEPE cause "The application is not able to keep up with the hardware acquisition" ?

Hi,everyone!

I am confusing about relationship between IEPE and hardware acquisition.

 

My newest VI could acquire data by NI-9234 card and write data to binary file. But when  I  set the "time record " button to be "ON"( to enable this VI write data to binary file) and then run the VI, an error would occur. It says that :

Possible reason(s):

The application is not able to keep up with the hardware acquisition.

Increasing the buffer size, reading the data more frequently, or specifying a fixed number of samples to read instead of reading all available samples might correct the problem.

 

Property: RelativeTo

Corresponding Value: Current Read Position

Property: Offset

Corresponding Value: 0.

 

My  previous version VI don't  have this problem ,but it can't  configure  the input channels to be  IEPE enable respectively. 

 

My test work require the sampling rate to be  51.2kHz, it couldn't be lower. And I have tried everything I can including looking up some topics in the forum ,but  no luck.

 

Q1:  Is there anyone could help me find something wrong in my block diagram ?

Q2:  Can you and give me some  solutions ? 

 

My  block diagram is attached below.

 

Your any suggestion  would be much helpful .Thanks  in advance .

 

Mittly 

lease Mark the solution as accepted if your problem is solved and help author by clicking on Star kudoes.
Message 1 of 3
(4,051 Views)

I am also getting the same error message using NI9234 for data acquisition and saving to a file once in every 60 seconds (25.6k samples at 25.6kHz sampling rate). the error occurs after every 15 to 20 minutes I run the code. Please give a solution to this. The forum suggests developing a producer-consumer design but could solve the issue. Please give a solution.

0 Kudos
Message 2 of 3
(2,695 Views)

@nikhilthoppil wrote:

I am also getting the same error message using NI9234 for data acquisition and saving to a file once in every 60 seconds (25.6k samples at 25.6kHz sampling rate). the error occurs after every 15 to 20 minutes I run the code. Please give a solution to this. The forum suggests developing a producer-consumer design but could solve the issue. Please give a solution.


Look in the example finder. A snippet is shown below of an example.

 

Use the the DAQmx Logging feature, much more efficient than Producer-Consumer. Also I hope you are not writing to the file once a minute, break up your writes into small amounts, say write data every 200 -500 ms.

 

mcduff

 

Snip.png

0 Kudos
Message 3 of 3
(2,684 Views)