Showing results for 
Search instead for 
Did you mean: 

Default Data Path and LVCompare

I am running into a problem which superficially seesm similar to:


I have relocated my Default Data directory of my LV 2012 SP1 installation so that it is on a SSD (mostly because of my compiled cache).


Now I realise that LVCompare doesn't seem to work.  Can it be that it's hard-wired to the default directory?  I do a lot of comparisons when committing my code and not having LVCompare working is hurting me. Funnily enough when I do a LVCompare from within the LV IDE (via Invoke node) it works fine but the standalone EXE doesn't work.


Is there an INI setting to fix this?  My LVCompare.exe doesn't seem to HAVE an INI file at the moment.....

0 Kudos
Message 1 of 9

Hmm, I don't actually have permission to write to this folder so maybe creating a shortcut with command-line commands (if possible) would be a possible solution?

0 Kudos
Message 2 of 9

Hi Intaris,


try to follow these instrucions. You can start LVCompare.exe from the CMD prompt with the absolut paths of the VIs you want to compare. Hope that helps.


Best regards,



Anna Vogl
Certified LabVIEW Developer
0 Kudos
Message 3 of 9

That's not the problem, LVCompare DOES get called, it just returns an error.


It returns:


An error occurred while running LVCompare<ERR>



<b> Complete call chain </b>

  NI_LVConfig.lvlib:Open Config Data (compatibility).vi


And the D:\path is the NEW Temp Path I have defined within my LV options.  I also forgot to mention earlier that I re-mapped TEMP and Default Data to my D Drive which is an SSD.  The mentioned LVCompare.ini does not exist at that address but rather at the OLD default address in my user folder.  So apparently LVCompare tries to load an INI file at the new address, but something else has actually written the file to the default address.  Naturally enough, this doesn't go too well.

0 Kudos
Message 4 of 9

I'm sorry, I missunderstood.


Where do you find the ini file? The LabVIEW installation itself is still on C:? I will see what I can find out.

Anna Vogl
Certified LabVIEW Developer
0 Kudos
Message 5 of 9

The labVIEW installation is on C: in the default directory.


LVCompare is at the default location.


The LabVIEW paths TEMP and DEFAULT DATA DIRECTORY are non-default on 😧


When I run LVCompare from the command line, it writes an ini file to the default TEMP directory on C: whereas it then tries to read it under the new directory on D:.

0 Kudos
Message 6 of 9



I did some research yesterday and didn't find anything that would help. I will try to contact my collegues in the US. I hope they can help us.

I could see the same behaviour with my LV 2015.


Can you, for now, change the Temp path back to it's original location?





Anna Vogl
Certified LabVIEW Developer
0 Kudos
Message 7 of 9

I normally use LVCompare programatically so the problem has limited scope.  I have code which iterates recursively through a given directory and runs LVCompare programatically on the VI and it's corresponding repository counterpart.  This way I can sort out those which have no "real" changes - mainly due to RT deploys - and revert them.


I'll just avoid calling it directly from Tortoise SVN for the time being.

0 Kudos
Message 8 of 9

My collegue in the US told me that copying the INI file from the default Temp folder to the new location would be a workaround for the issue.

I will file a corrective action request so that this problem will hopefully be solved for the following versions of LabVIEW.


Good luck with your project.



Anna Vogl
Certified LabVIEW Developer
0 Kudos
Message 9 of 9