LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQmx Task Name Constant and Channel constant is always empty

Solved!
Go to solution

Running into a recurring issue when attempting to write code which utilizes a new reference to my cDAQ-9189.

 

After dropping the new task constant into the block diagram and selecting the drop-down arrow, there are no entries available.

 

While selecting the I/O filter, all of the IOs are listed there. Just never from the block diagram. It was listed at other times, but now it's just unavailable.

 

The DAQ is connected to LAN and shows up just fine in NI MAX. Passes self-test without issues.

 

I followed an instruction on the NI support page to connect the DAQ BEFORE attempting to write code, but no difference for me.

0 Kudos
Message 1 of 3
(599 Views)

I'm currently repairing NI DAQ-MX from the package manager.

 

I'm using LabView version 2022 Q3 and DAQmx version 2022 Q4.

 

It may be worth noting that I also have a version of LabView 2014 SP1 installed on this PC.

0 Kudos
Message 2 of 3
(590 Views)
Solution
Accepted by topic author abenevides

I couldn't find a resolution to this, but ultimately the task/channel constants are not a requirement for my application.

 

The DAQmx drivers are functioning just fine in an automated set-up to build the string names for each channel query.

 

i.e. Building an array of strings formatted like "NI9403-0200AE00-Mod3/port0/line0:31" is working perfectly fine for me.

0 Kudos
Message 3 of 3
(515 Views)