Showing results for 
Search instead for 
Did you mean: 

Builder fails.

Go to solution

What can I do about this error?  I made a mass compile and got some errors. I replaced error.llb under vi.lib\utility that the compiler said was bad. 

Later on I tried to make a Build but got this error. Tech support? I bought this Labview for 2 month ago...However, It perhaps an easy thing to fix?



0 Kudos
Message 1 of 5
  • Can you give a bit more context?
  • What did you masscompile and why?
  • What was the original error? ("bad" is not descriptive).
  • You said you replaced something. Replaced with what?
  • What are you trying to build (exe, dll, source distribution, etc.).
  • Have you tried repairing the LabVIEW installation instead of randomly messing with system folders manually?
  • Is this LabVIEW 2020? 32bit or 64bit?
  • What toolkits and drivers do you have installed. Any third party toolkits/drivers?
0 Kudos
Message 2 of 5
Accepted by topic author TakeANap

I was in a hurry making some updates via Teamviewer in a project I delivered a few days before. I needed to make an EXE-file quick.  I have never had any problems with that before but this time the builder complained about some VI in error.llb. "**bleep**" I thought. "This is not happening!".  I made a masscompile on the whole project folder. I got more or less the same information. Some problems with error.llb. 

I checked the error.llb and saw that it had an new time from this morning. In panic I saved the error.llb to a new name and copied error.llb from my own computer (same installation, same version). Later on, the builder gave me the same error U can see in the pic. I switch back to original error.llb and tried again. Same error. 


It was no time for repair the installation. I downloaded the sourcecode to my computer, made a build and send the EXE back. 
It worked. I made a demonstration and the clients was happy. They took down the computer and sent it abroad.  


I know that they want to make more updates after a week in production so I must have this LV 2020 installation working. You gave me an idea. Repair...


Message 3 of 5

One more thing to do when you get such obscure compile errors besides repairing your LabVIEW installation would be to clear the compiler cache under Tools->Advanced->Clear Compiled Object Cache.


This is an SQL Lite database that LabVIEW uses to store precompiled object code for all your VIs in. It does maintain modification dates, data hashes and all that for every VI and only will recompile code if it determines that the original VI somehow changed since last compiled. If it for some reasons determines that the VI hasn't changed, it will retrieve the compiled object code from this database to reduce on compilation time. That database can get sometimes corrupted and give you very weird errors. Since it is only a cache that can be easily recreated, priority to debug such rare bugs hasn't been that great. It can for instance happen if your LabVIEW was in the process of updating that database and somehow was forced to shutdown during it, since that database is not fully transaction safe.

Rolf Kalbermatter
My Blog
Message 4 of 5

I always forget about that Clear cache, but it has solved many problems. 🙂

G# - Award winning reference based OOP for LV, for free! ADDQ VIPM Now on GitHub
"Only dead fish swim downstream" - "My life for Kudos!" - "Dumb people repeat old mistakes - smart ones create new ones."
0 Kudos
Message 5 of 5