LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Build exe doesn't work with RunTime 2011

Hello,

 

I'm trying to use humidity/temperature sensor of Rotronic with Lab View 2011. I got the example from the official website of Rotronic (It just have a dependency, a .dll included in the project, but I have copies of the .dll in other folders of the computer that can not be removed).

When I executed the application in my development computer no problem occurs. After that I generated the .exe file and it still running well. When I tried the .exe in my setup computer the following message appeared: "This VI is not executable. The full development version of Lab View is required to fix the errors". I debug the executable remotely and the run-arrow is broken, no broken wires or warnings appear.

It not happens when I generate the executable with Lab View 2017 in another development computer and ran the exe in the same setup computer. 

I have both run-time (2011/2017) installed in the setup and it works properly with other applications. I think that something is wrong to the dll's path, but I checked and all seems correct.

 

Some photos are attached to clarify. Ro3xdrv.dll is stored in the "data" folder 

 

Thanks in advanced! 

Download All
0 Kudos
Message 1 of 2
(1,801 Views)

Is the correct version of .NET installed on your setup computer?

Have you tried adding the .NET dll to the GAC?  Don't ask me how to do that.  Google is your friend if you don't know either. 

Having said that, it shouldn't be necessary because the 'data' subdirectory is a valid location according to this article.

aputman
------------------
Heads up! NI has moved LabVIEW to a mandatory SaaS subscription policy, along with a big price increase. Make your voice heard.
0 Kudos
Message 2 of 2
(1,773 Views)