LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Build Error: Error copying files

This is the error I see. Build was unsuccessful

 

build error.png

 

Visit the Request Support page at ni.com/ask to learn more about resolving this problem. Use the following information as a reference:

Error 1 occurred at AB_Destination.lvclass:Copy_File.vi -> AB_Source.lvclass:Copy_SourceItem.vi -> AB_Build.lvclass:Copy_Files.vi -> AB_Application.lvclass:Copy_Files.vi -> AB_EXE.lvclass:Copy_Files.vi -> AB_Build.lvclass:Build.vi -> AB_Application.lvclass:Build.vi -> AB_EXE.lvclass:Build.vi -> AB_Engine_Build.vi -> AB_Build_Invoke.vi -> AB_Build_Invoke.vi.ProxyCaller

Possible reason(s):

LabVIEW:  An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.
=========================
NI-488:  Command requires GPIB Controller to be Controller-In-Charge.

 

 

I upgraded to LV 2012 recently. I was able to build exes until today when I tried including ALL OTHER VI's and SUBVI's in "Always Included" section of source file settings and only MAIN.vi in Startup vis. I am not able to proceed. Please suggest tricks

I may not be perfect, but I'm all I got!
0 Kudos
Message 1 of 4
(2,890 Views)

I have had random errors before building.  Check the obvious like you have space available on your hard drive.  Other option is to exit LabVIEW, reopen, and try again to build your project.  Lastly, try pressing "Preview" in the build options to see if it indicates any issues / errors.

 

Matthew Fitzsimons

Certified LabVIEW Architect
LabVIEW 6.1 ... 2013, LVOOP, GOOP, TestStand, DAQ, and Vison
0 Kudos
Message 2 of 4
(2,880 Views)

The weird thing is when in development environment, everything works. When I choose preview, it builds too. But, when I actually build, I get the error.

 

I removed the folder and added it back again. Main thing I did is move one of the library (LLB) into program files user.llb folder ratherr than have it in my application, and have LV load the llb from there. That seemed to have solved the problem.

 

 

I may not be perfect, but I'm all I got!
0 Kudos
Message 3 of 4
(2,878 Views)

Have you tried to mass compile all the VIs from the project?

Alejandro C. | National Instruments
0 Kudos
Message 4 of 4
(2,858 Views)