Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

com port

Hi there,

 

We need to replace an old computer( windows 98)  which has labview program on, and it was linked to the test units using 3 PCI cards.

So I have copied and installed the labview program form the old computer to the new one, and bought a USB-XS USB to Sixteen Port Serial RS232 Converter to be used instead of the PCI cards.

But when I run the program labview can’t read the test units……so I think is something to do with the com port??.....

 

-       Do I have to change the com ports on the program ?

-       And if yes how can I do that?

Can someone help ….

thanks in advance

 

0 Kudos
Message 1 of 5
(2,028 Views)

What OS is running now?

Can you see the 16 ports in the system manager?

Can you access them via hyperterminal?

What version of LabVIEW are you using?

Do you use and installed the VISA driver? Version?

(Can you see them in MAX?)

(Do you have the source code?)

 

You can switch (renumber) the comports, however  maybe you don't need it ...

Are you shure that your devices run with standard RS232? Any critical timing involved? 

 

 

 

Greetings from Germany
Henrik

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'


0 Kudos
Message 2 of 5
(1,997 Views)

HI Henrik,

Thanks for your replay and the answers to your questions are:

-        Before  it was window 98, Now we running window XP

-       Yes I can see the 16 ports on the system manager.

-        No I’m not using the HyperTerminal

-       version of Labview : 5.1

-       I’m not sure about that to be honest.... how can I check it? (VISA driver? Version)

-       Sorry but I’m not sure what do you mean by( the source code)

-       yes I’m sure that my devices run with standard RS232 because the test unit are connected using.

0 Kudos
Message 3 of 5
(1,955 Views)

 


@xavoceon wrote:

HI Henrik,

Thanks for your replay and the answers to your questions are:

-        Before  it was window 98, Now we running window XP

-       Yes I can see the 16 ports on the system manager.

 

-       version of Labview : 5.1

-       I’m not sure about that to be honest.... how can I check it? (VISA driver? Version)

-       Sorry but I’m not sure what do you mean by( the source code)

-       yes I’m sure that my devices run with standard RS232 because the test unit are connected using.


 

-        No I’m not using the HyperTerminal

But can you make a connection to your device via hyperterminal?

(Involve that you know the serial settings and commands of your device

 

Greetings from Germany
Henrik

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'


0 Kudos
Message 4 of 5
(1,876 Views)

HI Henrik,

 

I'm not sure..how can i check that?

 

Regards

0 Kudos
Message 5 of 5
(1,853 Views)