Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Target Configuration wizard warns of LabVIEW 2014 support only.

I followed this:

Launch LabVIEW 2020 Comunity Edition and open the Target Configuration Wizard from Tools»MakerHub»LINX»LINX Target Configuration.

 

And it warns:

 

This wizard will install LabVIEW 2014 to the target device.  You will only be able to connect to and use the device from LabVIEW 2014.  

 

Here's how I messed it up...I installed LabVIEW 2019, and the Digilent Linx toolkit (not realizing it was only for 2014), then I installed LabVIEW 2020 Professional, then LabVIEW 2020 Community.  It seems community overwrites Professional because now Community is the only 2020 version installed.  Perhaps it didn't install the toolkit.  Then VIPM warns against installing NI LabVIEW LINX toolkit.

"Do not install this package if you are running LabVIEW 2020 Community Edition or later, as the Community Edition already includes the LINX Toolkit."

 

Tried to install anyways, and it said it was replacing VIs, then failed. now the dialogs won't load when I open Linx Target Configuration.

 

How do manually install and verify I have the right toolkit version installed for community?  Or should I reinstall some version of LabVIEW 2020 at this point?  

 

Greg Hahn
Sr. Hardware In the Loop Firmware Engineer - CLD
Milwaukee Tool - https://www.milwaukeetool.com/
0 Kudos
Message 1 of 9
(3,539 Views)

Anyone?  Ok I guess, I will uninstall and reinstall Community.

Greg Hahn
Sr. Hardware In the Loop Firmware Engineer - CLD
Milwaukee Tool - https://www.milwaukeetool.com/
0 Kudos
Message 2 of 9
(3,494 Views)

Reinstalled Community 2020, and LINX>Target configuration works, and I downloaded version 20.  Launched Example Project.  Created a build spec, downloaded startup exe to target.  Doesn't look like anything is running on the desktop.  Now through the project, it wont connect anymore.  Just says: Failed to connect to the target.  I'm able to ping it, and VNC into it, I disabled firewall.  What else does it need to connect to the target?

Greg Hahn
Sr. Hardware In the Loop Firmware Engineer - CLD
Milwaukee Tool - https://www.milwaukeetool.com/
0 Kudos
Message 3 of 9
(3,469 Views)

Reimaged it with Rasbian Feb 13 2020.  Installed Linx using Target configuration, and was able to connect.   Now right after I ran LINX-Blink (Advanced) or LINX - Blink the default example project, it doesn't seem to run the VI at all, and it disconnects:

"Warning: Connection to the target (raspberrypi) has been lost"

I have to reboot the PI to connect to it again through the project.  So, seems like lots of bugs, I probably have something configured wrong.

 

I am using the Raspberry PI3 hardware.  I think these projects are for the PI2 B and Pi3.  Not sure how to specify the correct GPIO pins.  I tried blinking GPIO 0,(which is available on the 3 but not the 2) and got this error:

The specified Digital Output channel (0) is not available on the Raspberry PI 2 Model B.

 

 

Greg Hahn
Sr. Hardware In the Loop Firmware Engineer - CLD
Milwaukee Tool - https://www.milwaukeetool.com/
0 Kudos
Message 4 of 9
(3,464 Views)

@Ghost_coder wrote:

Reinstalled Community 2020, and LINX>Target configuration works, and I downloaded version 20.  Launched Example Project.  Created a build spec, downloaded startup exe to target.  Doesn't look like anything is running on the desktop.  Now through the project, it wont connect anymore.  Just says: Failed to connect to the target.  I'm able to ping it, and VNC into it, I disabled firewall.  What else does it need to connect to the target?


I facing the same problem, still looking for solution. Once you deploy the real-time application, you must "Failed to connect to the target" on the next connection until you restart the labVIEW service.

0 Kudos
Message 5 of 9
(3,442 Views)

Still looking for a solution also.  I installed LabVIEW 2020 community on a clean Win10 VM, still connects the first time, and then doesn't run.  I'm using RPI 3 model B v.1.2.  Which service are you referring to, and on RPI, or Windows?

Greg Hahn
Sr. Hardware In the Loop Firmware Engineer - CLD
Milwaukee Tool - https://www.milwaukeetool.com/
0 Kudos
Message 6 of 9
(3,352 Views)

I'm facing the exact same issue

Did you manage to solve it?

0 Kudos
Message 7 of 9
(2,641 Views)

You got an old version of the Linx Toolkit installed on your machine. This could be either an old installation of LabVIEW 2014 with the according Linx Toolkit version 3.something or you made the mistake of installing the Linx Toolkit after installing the LabVIEW 2020 Community Edition. The Community Edition installer already contains the Linx Toolkit and installing it again over the Community Edition can only hurt you.

There is a VIPM package for the NI LabVIEW Linx by NI Toolkit version 1.0.0.9 that is for professional LabVIEW 2020 installations that do not come with this Toolkit preinstalled. LabVIEW 2020 Community Edition however does come with that Toolkit already installed so you do not need to install it again.

 

And there is the Digilent Linx by Digilent Toolkit version 3.0.1.192. This is compatible with LabVIEW 2011 and higher, BUT the option to deploy and run LabVIEW VIs to Raspberry Pi and BeagleBone Black boards ONLY works with LabVIEW 2014 and nothing else. If you install this into any other LabVIEW version you can NOT use it to target Raspberry Pi and Beaglebone Black boards.

 

If you got yourself into this mess somehow the only safe way is to wipe everything NI related from your disk and start again by installing the LabVIEW Community Edition. Never install the Diglent Toolkit in anything but LabVIEW 2014 if you want to target Raspberry Pi or Beaglebone Black.

Rolf Kalbermatter
My Blog
0 Kudos
Message 8 of 9
(2,634 Views)

@Ghost_coder wrote:

 

I am using the Raspberry PI3 hardware.  I think these projects are for the PI2 B and Pi3.  Not sure how to specify the correct GPIO pins.  I tried blinking GPIO 0,(which is available on the 3 but not the 2) and got this error:

The specified Digital Output channel (0) is not available on the Raspberry PI 2 Model B.


The Linx digital port numbering scheme is not the GPIO number but the pin number on the connector. Pin number 0 does not exist. Also the current Linx shared library only knows about Pi 2 Pin numbers.

 

So your GPIO 0 would be pin number 27, except that Linx does not know that pin as digital port since it wasn't supported on the Pi 2.

 

Linx supports currently         GPIO   4, 17, 18, 27, 22, 23, 24, 25,  5,  6,  12, 13, 19, 16, 26, 20, 21

which corresponds to Linx number  7, 11, 12, 13, 15, 16, 18, 22, 29, 31, 32, 33, 35, 36, 37, 38, 40

respectively

Rolf Kalbermatter
My Blog
0 Kudos
Message 9 of 9
(2,630 Views)