Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 2020 with LINX Toolkit then Connection lost when deploy

I followed this:

Launch LabVIEW 2020 Comunity Edition and open the Target Configuration Wizard from Tools»MakerHub»LINX»LINX Target Configuration.

 

And it warns:

 

This wizard will install LabVIEW 2014 to the target device.  You will only be able to connect to and use the device from LabVIEW 2014.  

 

Here's how I messed it up...I installed LabVIEW 2019, and the Digilent Linx toolkit (not realizing it was only for 2014), then I installed LabVIEW 2020 Professional, then LabVIEW 2020 Community.  It seems community overwrites Professional because now Community is the only 2020 version installed.  Perhaps it didn't install the toolkit.  Then VIPM warns against installing NI LabVIEW LINX toolkit.

"Do not install this package if you are running LabVIEW 2020 Community Edition or later, as the Community Edition already includes the LINX Toolkit."

 

Tried to install anyways, and it said it was replacing VIs, then failed. now the dialogs won't load when I open Linx Target Configuration.

 

How do manually install and verify I have the right toolkit version installed for community?  Or should I reinstall some version of LabVIEW 2020 at this point?  

 

0 Kudos
Message 1 of 7
(1,324 Views)

Personal I would uninstall everything and start over.  I would only install the one LabVIEW version you want to use.

 

I don't know of any information on how to fix and verify the correct LINX version is installed with LabVIEW Community Edition.

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 7
(1,292 Views)

LabVIEW Community Version 2020 is the same base system as other LabVIEW 2020 installations. The difference is mostly in the license that activates different features.

And the Community Edition 2020 installer comes with the Linx Toolkit 2020 already included while for other LabVIEW installers you have to download and install the Linx Toolkit separately, and make sure to install the 2020 version and not one of the previous ones. Most corporation do not want something like the Linx Toolkit installed on their computers, if for nothing else but disk space, but usually other consideration are at play too.

As to your hosed installation, all I can recommend is to completely wipe anything NI related from your hard disk and start from scratch. The recent LabVIEW installers got so complex that trying to fix hosed installation errors after the fact is basically more akin to playing Russian Roulette than anything else. It can go fine but often blows up completely.

Rolf Kalbermatter
My Blog
0 Kudos
Message 3 of 7
(1,288 Views)

I did that, but after installing labview community edition

it doesn't have Makerhub or linx by default! 

0 Kudos
Message 4 of 7
(1,250 Views)

I did that, but after installing labview community edition

it doesn't have Makerhub or linx by default !  

0 Kudos
Message 5 of 7
(1,246 Views)

As Makerhub doesn't really exist anymore I would expect that they removed that from the Community Edition too at least in the LabVIEW 2020 SP1.

Rolf Kalbermatter
My Blog
0 Kudos
Message 6 of 7
(1,238 Views)

So 

Can you tell me the steps to use Raspberry Pi via LabVIEW 

Which version of LabVIEW Worked for you and what did you install after to get raspberry pi support?

0 Kudos
Message 7 of 7
(1,212 Views)