Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

LINX - Blink (Simple).vi is not working with HC-05 over bluetooth com (Error 5003 and 1073807246)

Hi I am getting following error whenever I try executing the operation exactly as in this youtube video:  https://www.youtube.com/watch?v=vqr7M266u6U 

Error -1073807246 occurred at Property Node (arg 1) in VISA Configure Serial Port (Instr).vi->LMH-LINX.lvlib:Device.lvlib:Serial Open.vi->LMH-LINX.lvlib:Device.lvlib:Initialize Device.vi->LMH-LINX.lvlib:Initialize.vi->LMH-LINX.lvlib:Open Serial.vi->LINX - Blink (Simple).vi


Error 5003 occurred at :

Open Serial.vi >>
Initialize.vi >>
Initialize Device.vi >>
Synchronize.vi

 

Possible reason(s):

LabVIEW was unable to connect to the LINX device using the following settings:

Interface: Serial
COM Port: COM11

Please make sure that the LINX firmware is loaded on the device (Tools>>MakerHub >>LINX>>Firmware Wizard) that there are no other open connections to the device, then check the configuration settings, and try again.

If this error persists please search, then post on the LINX forums at www.labviewmakerhub.com/forums/linx

Software screenshots:
5.PNG
3.PNG2.PNG1.PNG
4.PNG

0 Kudos
Message 1 of 8
(251 Views)

Are you able to upload the firmware as shown in the video?  If so can you provide more information about your setup?  What version of LabVIEW are you using?  What Arduino device are you using?

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 8
(191 Views)

I was able to upload the firmware as shown in the video, but couldn't run the linx example as in the video.

I am using LabVIEW 2020 and an Arduino UNO board.


However NI visa works on my setup (projects like this https://www.youtube.com/watch?v=Kw4eOkq1B4k ) but Linx does not work at all.

0 Kudos
Message 3 of 8
(182 Views)

Are you using LabVIEW 2020 Community Edition or another version?  Did you install a package to use LINX?  If you installed a LINX package what package did you install?  

David Wilt
The New Standard LLC
0 Kudos
Message 4 of 8
(175 Views)

Hi David,

Yes I am using LabVIEW 2020 Community Edition.

I did install a package called Digilent LINX from VI package manager.  

0 Kudos
Message 5 of 8
(170 Views)

OK, installing the Digilent LINX package on top of LabVIEW 2020 Community Edition may be your issue.  LabVIEW Community Edition already comes with LINX installed and the package in package manager is known to cause issues when installed on top of the Community Edition.  Unfortunately the only known way to fix this issue is to completely uninstall LabVIEW and reinstall it.

 

Note: Do not install LINX from package manager when using the LabVIEW Community Edition as it is already included and this will mess up the installation.

David Wilt
The New Standard LLC
0 Kudos
Message 6 of 8
(164 Views)

Hi David, Thank you for your reply.

I just tried that.
I completely uninstalled Labview, cleaned up the National Instruments folder from the Program Files,
rebooted PC, then reinstalled Labview 2020 community edition.
This time I did not install anything from the VI package manager.

Unfortunately these errors still persist.
I do believe HC-05 receives some kind of signal from PC because it stops its random blinking whenever I run the labView application. But every time I end up getting errors.

I even tried this experiment with school computers that have labview 2018, I still get the same errors.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0 Kudos
Message 7 of 8
(152 Views)

Sorry I cannot help any further as I am not familiar with the HC-05.  It sounds like your setup is correct now.

 

The one thing I did notice is that the pin that was set in your screenshot was different then what was set in the video.  If you have the wrong pin could that be causing the HC-05 to not behave has expected?

David Wilt
The New Standard LLC
0 Kudos
Message 8 of 8
(122 Views)